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Regulation Information
Europe
This product complies with the requirements of the R&TTE Directive (1999/5/ED). A copy of the full 
Declaration of Conformance may be obtained at http://eu.sonos.com.

 Attention In France, operation is limited to indoor use within the band 2.454-2.4835 GHz.  
(Attention. En France, l’utilisation en intérieur est limitée à la bande de fréquences 2,454-2,4835 GHz.)

USA
This equipment has been tested and found to comply with the limits for a Class B digital device, pursuant to 
part 15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful 
interference in a residential installation. This equipment generates, uses and can radiate radio frequency 
energy and, if not installed and used in accordance with the instructions, may cause harmful interference to 
radio communications. However, there is no guarantee that interference will not occur in a particular 
installation. If this equipment does cause harmful interference to radio or television reception, which can be 
determined by turning the equipment off and on, the user is encouraged to try to correct the interference by 
one or more of the following measures: 

• Reorient or relocate the receiving antenna.
• Increase the separation between the equipment and receiver.
• Connect the equipment into an outlet on a circuit different from that to which the receiver is con-

nected.
• Consult the dealer or an experienced audio technician for help. Modifications not expressly ap-

proved by the manufacturer may void the user's authority to operate the equipment under FCC 
rules.

Canada
This Class B digital apparatus complies with Canadian ICES-003 and RSS-210. 
Industry Canada
The installer of this radio equipment must ensure that the antenna is located or pointed such that it does not 
emit RF field in excess of Health Canada limits for the general population; consult Safety Code 6, obtainable 
from Health Canada’s Web site www.hc-sc.gc.ca/rpb.

RF Exposure Requirements
To comply with FCC and EU exposure essential requirements, a minimum separation distance of 20cm (8 
inches) is required between the equipment and the body of the user or nearby persons.

Recycling Information

  
 

This symbol on the product or on its packaging indicates that this product shall not be treated as household 
waste. Instead please deliver it to the applicable collection point for the recycling of electrical and electronic 
equipment. By recycling this product correctly, you will help conserve natural resources and prevent 
potential negative environmental consequences. For more detailed information about recycling of this 
product, please contact your local city office, your household waste disposal service or the shop where you 

purchased the product.

http://eu.sonos.com
www.hc-sc.gc.ca/rpb


Overview

Your Computer Requirements

To play the digital music files stored on your computer, your computer network must 
meet the following requirements:

Network Requirements

• You must have an Ethernet network interface connection in your PC. If you do 
not have one, you will need to buy and install a Network Interface Card (NIC) be-
fore proceeding.

• DSL/cable modem, or LAN-based, high-speed Internet connection.

• If you currently have a cable or DSL modem connected directly to your comput-
er, you should install a router between your modem and your computer to 
enhance your computer’s security, and to share the Internet connection with 
your Sonos Digital Music System and other devices. If you do not have a router, 
you should purchase and install one before proceeding.

System requirements

• 500 MHz processor or better 

• 128 MB RAM minimum/256 MB RAM recommended 

• Network hardware as described above

Important:  Your network must have a high-speed Internet connection, as the Sonos Digital 
Music System is designed to provide you with online software updates. Your Sonos system 
must be registered to receive these updates so be sure to register during the setup process. At 
no time is your e-mail address provided to other companies.
Chapter 1
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Compatible operating systems

• Windows® XP, including Windows XP® Media Center

• Windows® 2000

• Macintosh® OS  X, (10.3 or later)

Compatible playlist formats

• iTunes®

• Rhapsody™

• Musicmatch™

• Windows Media Player®

• WinAmp®

Compatible music file formats

• MP3

• WMA (not including lossless)

• AAC (MPEG4)

• WAV/LPCM (uncompressed)

• AIFF (uncompressed)

• FLAC (lossless)

• Ogg Vorbis

• Apple Lossless

• Audible Format 4

Compatible streaming formats

• MP3

• WMA (HTTP)

Please visit our Web site at http://faq.sonos.com/specs for the latest system 
requirements and compatible audio formats. 

Technical Support
For help with troubleshooting and support issues, visit our Support Web site. If you 
cannot solve the problem there, contact us by telephone.

http://faq.sonos.com/specs
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• Web site: www.sonos.com/support

• Telephone: Visit our Web site at www.sonos.com/support/phonesupport to find 
the correct telephone number for your country.

Additional Information
• For the latest product documentation, go to http://sonos.com/support/docu-

ments. 

• For answers to common or uncommon questions, go to 
http://sonos.com/support/faqs. 

• For the latest system requirements or compatible audio formats, go to  
 http://faq.sonos.com/specs.

• For the latest Sonos Digital Music System product news, go to  
http://www.sonos.com. 

System Registration
Registering your music system allows you to receive technical support, software 
upgrades, and a free 30-Rhapsody trial subscription. At no time is any of your 
information provided to other companies.

To register using Desktop Controller software

Select Sonos System Registration from the Help menu (Windows) or the Sonos 
menu (Macintosh).

To register using Sonos Controller

1. From the Music menu, click System Settings.

2. Click Advanced Settings>System Registration.

Language Preference
Using Desktop Controller for Windows

1. From the File menu, select Preferences.

2. Select the General tab.

3. Select your language preference from the Desktop Controller Language field. 

http://www.sonos.com
http://www.sonos.com
http://faq.sonos.com
http://www.sonos.com/support/phone_support
http://www.sonos.com/support/documents
http://faq.sonos.com/specs
http://www.sonos.com/support
http://faq.sonos.com
http://www.sonos.com/support/documents
http://www.sonos.com/support/documents
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Using Desktop Controller for Macintosh

The Desktop Controller will try to use the language you have selected in your OS X 
operating system (System Preferences).

Using Sonos Controller

1. From the Music menu, select System Settings>Controller Settings>Advanced 
Settings>Language.

2. Select your language preference, and then touch OK.

Music Library Preferences

Sort Folders By Preference

You can set the sorting preference for music folders that are accessible from your music 
library. You can choose to sort by:

• Track name

• Track number

• Filename

To set using Desktop Controller software

1. From the File menu (Windows) or Sonos menu (Macintosh), select Preferences.

2. Click the Library tab, and select your sort order preference from the drop-down 
Sort By field.

To set using Sonos Controller

1. From the Music menu, select System Settings>Advanced Settings>Sort 
Folders By.

2. Select your sort order preference, and then touch OK.

Compilation Albums

If your music collection contains compilations and soundtracks, you may want to 
group these songs together in your music library instead of viewing them by individual 
artist. This means that any artists that appear solely on compilations will not appear in 
your Artists list. There are two ways you can group compilations within Sonos:
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Group by iTunes Compilations

iTunes normally organizes your iTunes Music folder as [Artist]/[Album]/[Track name]. 
iTunes has a feature that allows you to group your compilations albums together. This 
will organize your compilations and soundtrack albums as [Compilations]/[Album]/
[Track name]. 

Within iTunes:
1. Mark individual tracks as being part of compilations by highlighting the track and 

then selecting File>Get Info. 

2. Check the Part of a compilation checkbox. 

3. From iTunes Preferences, check the Group Compilations When Browsing 
checkbox. This will group the tracks you’ve marked as compilations.

Within Sonos:
You can organize your Sonos music library to use this iTunes compilation view.

Using the Desktop Controller software

1. Select File (or Sonos)>Preferences. 

2. From the Library tab, select Group using iTunes compilations.

3. If you would like to see the individual artists displayed in a Contributing Artist view, 
check the Show Contributing Artists in the Music Library checkbox. If this box 
is not checked, the Contributing Artists view will not display.

Using the Sonos Controller 

1. From the Music menu, select System Settings>Music Library Management> 
Compilation Albums.

2. Select Group Using iTunes Compilations, and touch OK

Group by AlbumArtists

Windows Media Player, as well as some other players, use the Album Artist category to 
group compilations and soundtrack albums (the Album Artist is the person, group or 
composer the album would be filed under in a store.) 

You can organize your Sonos music library to use the AlbumArtist compilation view.

Using the Desktop Controller software

1. Select File (or Sonos)>Preferences. 
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2. From the Library tab, select Group using AlbumArtists. 

3. If you would like to see the individual artists displayed in a Contributing Artist view, 
check the Show Contributing Artists in the Music Library checkbox. If this box 
is not checked, the Contributing Artists view will not display.

Using the Sonos Controller

1. From the Music menu, select System Settings>Music Library Management> 
Compilation Albums.

2. Select Group Using AlbumArtist, and then touch OK

Contributing artists

Contributing Artists are those who appear on individual tracks within an album, 
including those on a compilation or soundtrack album. You can set your preferences to 
show or hide these individual artists within a Contributing Artists view.

Using the Desktop Controller software

1. Select File (or Sonos)>Preferences. 

2. From the Library tab, check or uncheck the Show Contributing Artists in the 
Music Library checkbox. If this box is not checked, the Contributing Artists view 
will not display.

The Show Contributing Artists preference setting you select applies only to this 
Desktop Controller. If you have another Desktop or handheld Controller, you can select 
a different Contributing Artist view for it.  

Using the Sonos Controller

1. From the Music menu, select System Settings>Music Library Management> 
View Contributing Artists.

2. Select On or Off, and press OK.

The View Contributing Artists preference setting you select applies only to this  
handheld Controller. If you have another Desktop or handheld Controller, you can 
select a different Contributing Artist view for it.  

Don’t group compilations

If you choose not to group compilation albums, the individual artists will display within 
your Artists view. 
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Using the Desktop Controller software

1. Select File (or Sonos)>Preferences. 

2. From the Library tab, select Do not Group Compilations. All of the individual 
artists will then appear in the Artists view.

Using the Sonos Controller

1. From the Music menu, select System Settings>Music Library Management> 
Compilation Albums.

2. Select Do not group compilations, and then touch OK
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Windows Shortcut Keys 

FUNCTION KEY SEQUENCE 

Help F1

Album Art F4

Equalizer F5

Unmute All Zones F6

Mute All Zones F7

Mute Zone F8

Volume Down F9

Volume Up F10

Next CTRL + F

Play/Pause CTRL + P

Play Now CTRL + N

Play Next CTRL + Shift + N

Previous CTRL + B

Add to Queue CTRL + Q

Shuffle CTRL + H

Repeat CTRL + T
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Macintosh Shortcut Keys 

FUNCTION KEY SEQUENCE 

Add to Queue Option + Command + A

Album Art Command + —

Clock and Alarms Shift + Command + C

Drop Zone Shift + Command + D

Equalizer Command + =

Help Command + ?

Hide Music Library Command + L

Library Command + 1

Line-In Command + 5

Link Zone Shift + Command + L

Music Services Command + 2

Mute All Zones Option + Shift + Command + Down Arrow

Mute Zone Option + Command + Down Arrow

Next Command + Right Arrow

Next Zone Shift + Command + Down Arrow

Play/Pause space

Play Now Option + Command + P

Play Next Option + Command + N

Preferences Command + , 

Previous Command + Left Arrow

Previous Zone Shift + Command + Up Arrow
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Radio Command + 4

Repeat Option + Command + R

Schedule Music Index Updates Shift + Command + U

Set Up Music Library Shift + Command + M

Set Up Zones Shift + Command + Z

Shuffle Option + Command + S

Sleep Timer Shift + Command + S

Sonos Playlists Command + 3

Unmute All Zones Option + Shift + Command + Up Arrow

Update Music Index Now Shift + Command + I

Volume Down Command + Down Arrow

Volume Up Command + Up Arrow



ZonePlayer Setup and Operation

1-2-3 Setup
It takes just 3 steps to get your Sonos Digital Music System up and running: 

Connect speakers or an external amplifier to your ZonePlayer 

Connect the first Sonos ZonePlayer (with Ethernet cable supplied) to your home 
network

Install the computer software (or use a Controller) to configure your music system

ZP100 - How to Set Up Your Music System
Carefully unpack your Sonos ZonePlayer(s). Then follow the step-by-step instructions 
on the following pages to ensure that you set up your speakers and your ZonePlayer(s) 
correctly. 

After at least one ZonePlayer has been set up, you can follow the instructions on the 
Controller screen to add a new Controller to your Sonos Digital Music System.

If you should experience any difficulty during the setup process, see Appendix A for 
additional help.

Note:   Your network must have a high-speed Internet connection, as the Sonos Digital Music 
System is designed to provide you with online software updates. Your Sonos system must be 
registered to receive these updates so be sure to register during the setup process. Sonos does 
not share your e-mail address with other companies.

1 

2 

3 
Chapter 2
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1

2

Step 1: Set Up Speakers/Apply Power

Your speaker’s power rating should be at least 75W for 8 Ohm speakers, and at least 
150W for 4 Ohm speakers. Do not connect speakers rated at less than 4 Ohms. 

1. When making connections, ensure that none of the strands of your speaker wire 
come in contact with an adjoining terminal on the rear panel. 

2. Use your thumb or finger to firmly push the spring-
loaded speaker connector post inward to reveal the 
connection hole.

3. Insert the stripped end of the speaker wire into the hole, 
then release. The stripped portion should be caught firmly 
in the connector post. 

4.  Repeat to install the other speaker wires.

5.  Attach the power cord to the ZonePlayer and plug into a wall outlet.

The Mute button indicator and the ZonePlayer Status indicator will begin to flash.  
(If this ZonePlayer was previously connected to another Sonos Digital Music System, 
the ZonePlayer Status indicator may light solid white instead.)

Step 2: Connect First ZonePlayer ZP100

1. Connect the Ethernet cable from an open port on your router to any of the four (4) 
Ethernet switch connectors on the back of your ZonePlayer (see A in the diagram 
below).

• If your modem is currently plugged into the only network interface connector 
on your computer, you should install a standard router before continuing. If you 
don’t have a router, go to http://faq.sonos.com/norouter for instructions. 

Or,

• If you have structured (built-in) wiring that connects to a router located else-
where in your home, you can connect the Ethernet cable from a live wall plate 
into one of the four Ethernet switch connectors on the back of your ZonePlayer 

Note:   Connect the red (+) and black (-) terminals from each speaker to the corresponding 
terminals on the ZonePlayer. Mismatching of polarities will result in weak central sound, and a 
distorted sense of sound direction. 

http://faq.sonos.com/norouter


Chapter 2:  ZonePlayer Setup and Operation 2-3
(see B in the diagram below).

2. If you don’t have an open port on your router, you can disconnect your computer 
from the router and connect it to the ZonePlayer instead. Then you can connect 
the ZonePlayer into the router port the computer was previously plugged into. 

Note:   To maintain your computer’s security, do not connect the ZonePlayer directly to your 
cable/DSL modem.
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3

 

Step 3: Install software

If your operating system is Macintosh® OS X (version 10.3 or later), Windows® 2000 or 
Windows® XP, insert the Sonos System Setup CD-ROM and follow the on-screen 
instructions to install the software which will guide you through the process of 
configuring your music system, and setting up access to your music files.

• If the Desktop Controller software for Windows does not start automatically, run 
“d:/setup.exe” replacing “d” with your CD-ROM drive’s letter as necessary.

• If you have a different operating system, see "System Setup Using Controller" on 
C-1.

• If you have only a NAS device without a router, see "Setup Using Only a NAS De-
vice (no router)" on C-4.

 

Caution: Do not place any items on top of your ZonePlayer. This may impede the air flow 
and cause your ZonePlayer to overheat.

Note:   Firewall software such as Norton Internet Security, McAfee Personal Firewall, 
ZoneAlarm, OS X Firewall, or Windows® Service Pack 2 can block the operation of your Sonos 
Desktop Controller software. During installation, you may see prompts from your firewall 
software indicating that the Sonos application is attempting to perform certain operations. 
You should always allow full access to the Sonos application. You may also need to change the 
settings of your firewall software to ensure that Windows file sharing is not blocked. See 
"Firewall Information" or go to our Web site at http://faq.sonos.com/firewall for detailed 
instructions.

Now you can plug your Sonos Controller 
into the power adapter and follow the 
prompts on the Controller’s screen to add it 
to your music system. You can use the 
Controller while it is charging.

http://faq.sonos.com/firewall


Chapter 2:  ZonePlayer Setup and Operation 2-5
ZP80 - How to Set Up Your Music System 
Follow the step-by-step instructions to ensure that you set up your ZonePlayer ZP80(s) 
correctly. 

• If you should experience any difficulty during the setup process, please go to  
www.sonos.com/support for additional help.

• The first ZonePlayer you set up should connect to your home network using a 
standard Ethernet cable (supplied). If your computer only has a wireless connec-
tion, visit our Web site at http://faq.sonos.com/wireless. 

If you are setting up a new Sonos system 

Step 1: Attach the power cord and plug in the ZonePlayer ZP80.

Step 2: Connect a standard Ethernet cable (supplied) from either of the two (2) 
Ethernet switch connectors on the back of your ZonePlayer ZP80 to an open port on 
your router (see A in the diagram below). Do not connect the ZonePlayer directly to 
your cable or DSL modem unless your modem has a built-in router.

If you don’t have a router, go to http://faq.sonos.com/norouter for instructions. 

If you don’t have an open port on your router, you can disconnect your computer from 
the router and connect it to the ZonePlayer ZP80 instead. Then connect the 
ZonePlayer into the router port the computer was previously plugged into.

http://faq.sonos.com/norouter
http://www.sonos.com/support
http://faq.sonos.com/wireless
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If your router has only 1 port or no unused ports, go to http://faq.sonos.com/
norouterport for additional information. 

Step 3: Insert the Sonos System Setup CD-ROM (included with your ZonePlayer) and 
follow the prompts to connect your ZonePlayer ZP80 and set up access to your music 
files. 

For use with:
• Windows XP, including Windows XP  

Media Center
• Windows 2000
• Mac OS X 

If your operating system is not one of these, go to 
http://faq.sonos.com/nodcr for setup assistance. 

http://faq.sonos.com/norouterport 
http://faq.sonos.com/nodcr
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Step 4: Attach the ZonePlayer ZP80 to an external amplified device. See "Using Line-
out" on 2-12.

If you are adding to an existing Sonos system 

Step 1: Attach the power cord and plug in the ZonePlayer ZP80.

Step 2: If you are making a wired connection, connect a standard Ethernet cable. If you 
are making a wireless connection, skip this step and continue.

Step 3: Choose one of the following options: 

• Use the Sonos Controller to add the ZonePlayer ZP80 to your music system by se-
lecting System Settings>Add a ZonePlayer from the Music menu. Or,

• Use the Desktop Controller software to add the ZonePlayer ZP80 to your music 
system by selecting Zones>Set Up Zones>Add.

Step 4: Attach the ZonePlayer ZP80 to an external amplified device. See "Using Line-
out" on 2-12.

Note:   Firewall software such as Norton Internet Security™, McAfee™ Personal Firewall, 
Windows® Service Pack 2, or Mac OS X built-in firewall, can block the operation of your Sonos 
Desktop Controller software. During installation, you may see prompts from your firewall 
software indicating that the Sonos application is attempting to perform certain operations. 
You should always allow full access to the Sonos application. You may also need to change 
the settings of your firewall software to ensure that Windows file sharing is not blocked. Please 
go to our Web site at http://faq.sonos.com/firewall for detailed instructions.

Important: If you want to replace the wired ZonePlayer in your music system with a 
ZonePlayer ZP80, first add the new ZonePlayer ZP80 to your music system (steps below). You 
can then unplug the wired ZonePlayer, replace it with the ZP80, and move the original 
ZonePlayer to a new location.

http://faq.sonos.com/firewall 
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Adding More Sonos Components
Add A ZonePlayer

If your house has structured (built-in) wiring, you can make a ‘wired’ connection to an 
additional ZonePlayer. Otherwise, make a wireless connection. 

1. Place the ZonePlayer in the room you have selected.

2. If you are making a wired connection, connect a standard Ethernet cable from 
either your router, another ZonePlayer, or a ‘live’ network wall plate to any of the 
Ethernet switch connections on the back of the new ZonePlayer. If you are making 
a wireless connection, proceed to step 3.

3. If you are adding a ZP100, attach speakers to your ZonePlayer (see "Step 1: Set Up 
Speakers/Apply Power" on 2-2) . If you are adding a ZP80, connect to an external 
amplified device (see "Using Line-out" on 2-12).

After you plug the ZonePlayer into a wall outlet, the Mute indicator and the 
ZonePlayer Status indicator will begin to flash. (If this ZonePlayer was previously 
connected to another Sonos Digital Music System, the ZonePlayer Status indicator may 
light solid white instead.)

4. Choose one of the following options:

• Use the Desktop Controller to add the ZonePlayer to your Sonos Digital Music 
System by selecting Zones>Set Up Zones>Add.

Or,

• Use a Sonos Controller to add the ZonePlayer to your Sonos Digital Music System 
by selecting System Settings>Add a ZonePlayer from the Music menu. 

Caution: Do not place any items on top of your ZonePlayer. This may impede the air flow 
and cause your ZonePlayer to overheat. 

Mute; flashes green

Status Indicator; flashes white
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During the setup process, you will be asked to press and release the Mute and Volume 
Up buttons simultaneously on the ZonePlayer you are adding to the Sonos Digital 
Music System.

• You may release the buttons as soon as the Mute indicator (green) and the 
ZonePlayer Status Indicator (white) start to blink alternately (this takes ap-
proximately 1 second.)

• When the ZonePlayer has been successfully added to your music system, the 
Mute indicator will go out and the ZonePlayer Status indicator will change to 
solid white.

Add a Controller

You should charge your new Sonos Controller when you remove it from the packaging. 
Plug it into the power adapter, and then follow the Controller’s on-screen prompts to 
add it to your music system (you can use the Controller while it is charging.)

When and why should I use a wireless connection?

The Sonos Digital Music system uses a built-in wireless connection to communicate 
between ZonePlayers. You can place ZonePlayers anywhere without physically 
connecting them to your computer network, as long as they are within transmitting 
range (up to 100 ft. depending upon your home’s layout). This means that you do not 
need to go to the effort of installing cables, and you can relocate your ZonePlayer(s) 
easily.

 

Use wireless connections when:

• You do not want to install network cables

• You may want to move the ZonePlayer 

• There is enough signal strength for the ZonePlayer to transmit and receive data 
reliably

Note:   Thick walls, 2.4 GHz cordless telephones, or the presence of other wireless devices can 
interfere with or block the wireless network signals from your Sonos Digital Music System. 
Once you locate your ZonePlayer, if you are experiencing difficulty, it is advisable to relocate 
the ZonePlayer, change the wireless channel your music system is operating on, or make a 
wired connection (Ethernet cable) either from your router to the ZonePlayer, or from one 
ZonePlayer to another. If you are having trouble placing your units within wireless range of 
each other, you can go to our Web site at http://faq.sonos.com/range for more information.

http://faq.sonos.com/range
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Renaming a ZonePlayer
If you name a ZonePlayer incorrectly, or if you move your ZonePlayer to another room, 
you can rename it to suit your preference.

To rename using Desktop Controller software 

1. From the Zones menu, click Set Up Zones.

2. Select the ZonePlayer you wish to change, and click Settings.

3. From the Zone Name tab, select a name from the list, or type a new name for this 
ZonePlayer in the Zone Name field, and then click OK.

To rename using Sonos Controller

1. From the Music menu, select System Settings>ZonePlayer Settings and press 
OK.

2. Use the scroll wheel to highlight the zone you wish to change, and press OK.

3. Select ZonePlayer Name, and press OK.

4. Choose one of the following options:

• Use the scroll wheel to select a new name from the list, and then press OK.

Or,

• Type a different name by selecting Enter New. 

• Use the scroll wheel to select each letter, pressing OK after each entry.
• Press Accept to accept the new name, or press Cancel to leave the screen 

without making a change.

Turning Off White Status Indicator
If you have a ZonePlayer located in a bedroom, you may want to turn off the Status 
Indicator Light located on the front of the ZonePlayer. When the ZonePlayer is in 
normal operation, the white light will not display. However, if the ZonePlayer status 
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indicator begins to flash amber, see "ZonePlayer Status Indicator Explanations" on A-
8for additional information.

To turn off using Desktop Controller software

1. From the Zones menu, click Set Up Zones.

2. Highlight the ZonePlayer you wish to adjust, and click Settings.

3. From the Status Indicator Light tab, select On or Off and click OK.

To turn off using Sonos Controller

1. From the Music menu, select System Settings>ZonePlayer Settings, and press 
OK.

2. Use the scroll wheel to highlight the zone you wish to affect, and press OK.

3. Select White Status Indicator Light, and press OK.

4. Select On to turn the light on during normal operation, or Off to turn the light off 
during normal operation, and press OK.

Changing a ZonePlayer’s Operating Mode
You can use a ZonePlayer simply to extend the wireless range of your Sonos Digital 
Music System and not to play music by placing the ZonePlayer into Sonos Extender 
mode. A ZonePlayer operating in Sonos Extender mode is sometimes referred to as a 
hidden ZonePlayer, and will not appear in your Zones menu.

The ZonePlayer must already be part of your Sonos Digital Music System in order to 
change its mode of operation. 

To change using Desktop Controller software

1. From the Zones menu, select Set Up Zones.

ZonePlayer Status Indicator Light; 
white when in normal operation
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2. Highlight the ZonePlayer you want to change, and click Settings.

3. Select the Advanced tab.

4. Select either Normal Mode or Sonos Extender Mode, and click OK.

To change using Sonos Controller

1. From the Music menu, select System Settings>ZonePlayer Settings. 

2. Select the ZonePlayer you want to change, and click OK.

3. Select ZonePlayer Mode, and click OK.

4. Select either Normal or Sonos Extender mode, and click OK.

When a ZonePlayer is in Sonos Extender mode, it does not display in your Zones menu. 
When you change it back to normal operation using the ZonePlayer Settings screen, 
it will appear as an unnamed zone and you can rename it at that time.

Turning off Music System
Your Sonos Digital Music System is designed to be always on; the system uses minimal 
electricity whenever it is not playing music. To stop streaming music in all zones, you 
can use the Pause All feature. 

• Using the Sonos Controller, select Pause All from the Zone menu.

• Using the Desktop Controller software, select Pause All from the Play menu.

Your ZonePlayers will remain off until you click Play to restart each zone or zone group. 

Using Line-out 
You can easily connect your home theater, stereo, or powered speakers to a 
ZonePlayer. Depending on your ZonePlayer model, you can use analog or digital audio 
outputs to connect to an external amplifier. The ZonePlayer ZP80 model has both 
digital and analog outputs, while the ZonePlayer ZP100 model has analog outputs.

For additional information on connecting audio devices, you can go to our Web site at   
http://faq.sonos.com/cables. 

To connect to a home theater

1. Choose one of the following options:

• If you have digital inputs on your home theater receiver and your ZonePlayer 

http://faq.sonos.com/cables
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supports digital audio output, you can use either a TOSLINK™ optical audio ca-
ble or a digital coaxial cable to connect the ZonePlayer's digital output to the 
digital input on your home theater receiver.

• If you have analog inputs on your receiver, use a standard RCA audio cable to 
connect a ZonePlayer's analog audio output to the audio inputs on your home 
theater receiver. 

2. Select the proper input channel on your home theater system.

3. If you are setting up a new ZonePlayer, plug in your ZonePlayer, and then choose 
one of the following options:

• Use the Desktop Controller software to add the ZonePlayer to your Sonos Dig-
ital Music System by selecting Zones>Set Up Zones>Add.

• Use the Sonos Controller to add the ZonePlayer to your Sonos Digital Music 
System by selecting System Settings>Add a ZonePlayer from the Music 
menu. 

To control the volume from home theater

Set the line-out level on this ZonePlayer to Fixed by selecting one of the following 
options:

• Using the Desktop Controller software, select Set Up Zones from the Zones 
menu. Select the ZonePlayer attached to your home theater, and then click Set-
tings. Click the Line-Out tab, and choose Fixed. 

• Using the Sonos Controller, from the Music menu, select System Settings. Se-
lect ZonePlayer Settings, and use the scroll wheel to highlight the ZonePlayer 
attached to your home theater. Select Line-Out Level, and choose Fixed.

To control the volume from Sonos system

1. Adjust your home theater or other audio device's volume to typical listening 
volume. 

2. Set the line-out level on this ZonePlayer to Variable by selecting one of the 
following options:

Note:   When you change the line-out level to Fixed on your ZonePlayer, you will not be able 
to adjust the volume or the equalization settings using your Sonos Controller.
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• Using the Desktop Controller software, select Set Up Zones from the Zones 
menu. Select the ZonePlayer attached to your home theater, and then click Set-
tings. Click the Line-Out tab, and choose Variable. 

• Using the Sonos Controller, from the Music menu, select System Settings. Se-
lect ZonePlayer Settings, and use the scroll wheel to highlight the ZonePlayer 
attached to your home theater. Select Line-Out Level, and choose Variable.

3. Use the Controller to adjust the volume on your Sonos system so you can hear 
music. This may be at the high end of the volume scale.

4. If desired, you can readjust the volume on your home theater system so that the 
volume range for the Controller falls within your typical listening range. 

To connect to a computer or powered speakers

• If you are connecting to your computer: You will need a stereo mini-to-RCA Y 
adapter audio cable (one 1/8-inch stereo mini-plug to dual RCA male connec-
tors) to connect the ZonePlayer’s analog audio output to the computer’s audio 
input. 

• If you are connecting to powered speakers: You may need a Y adapter audio 
cable (one 1/8-inch stereo mini-plug to dual RCA male connectors) to connect 
the computer’s speakers to the audio outputs on the ZonePlayer. If your speak-
ers have a male 1/8-inch stereo plug, you can attach a female-to-female coupler 
between the speaker plug and the Y adapter audio cable, or you can use a Y-
adapter audio cable (one 1/8-inch Female connector to dual RCA male connec-
tors). 
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Using Line-in 
You can play music from an external line-in source such as a CD player, portable music 
player, or television that is connected to your Sonos Digital Music System. This audio 
can be streamed to any ZonePlayer(s) in your house. So, connect your CD player to the 
Sonos Digital Music System and listen to the CDs you haven’t had a chance to rip to 
your music library, or connect to your TV and listen to the football game on the patio 
while cooking on the grill. 

• Use a standard RCA cable to plug the external source into the analog Audio In 
connections on the back of your ZonePlayer. The source device will automatical-
ly be detected.

• To connect a portable player to the ZonePlayer, you will need a 1/8 inch mini-ste-
reo to RCA audio cable. Plug the mini-stereo end into the portable device and 
the RCA end into the Audio In connection on the ZonePlayer.   

Note:   You can listen to music from the external device in any zone, and use the Sonos Digital 
Music System to control the volume settings. However you must control the playback 
(forward, pause, etc.) from the line-in source. If you have Compressed encoding selected, you 
will notice a delay before the music starts to play.
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To connect using Desktop Controller software

1. From the Music Library pane, click the Line-In tab. (On a PC, you may need to 
click >> to select the Line-In tab if your screen resolution is set low).

2. To play music from this source, select the audio component, and click Play Now.

3. To change the settings for this source, highlight the audio component, and click 
Set Up to display the ZonePlayer Settings screen.

• (You can also display this screen by selecting Set Up Zones>Settings from the 
Zones menu. Highlight the ZonePlayer your line-in source is connected to, and 
click Settings.)

4. From the Line-In tab, select an audio component type from the Source IconType 
list. 

5. Type the name you want to use for this source (for example, CD Player or MP3 
Player).

6. Select the line-in level appropriate for this device, and then click OK.

• The default (typical) line-in level for the selected device type is displayed. You 
can increase or decrease the level, but if the level is set too high, you may expe-
rience clipping at higher volume levels.

To connect using Sonos Controller

From the Music menu, select Line-In Sources and touch OK. 

• To play music from this source, highlight it and touch OK. 

• To change the name of the component, highlight it and select Edit Name. 
Choose a new name from the list, and touch OK.

• To change the line-in level for this component, highlight it and select Edit Line 
Level. Choose the line-in level appropriate for this device, and click OK.

A default (typical) line-in level is automatically assigned when you select a source 
name. If the volume sounds too low, you can select a higher line level for this 
device. You may experience clipping at higher volume levels if you set the level 
too high. 

To change the line-in encoding for these components, see "Line-In encoding" on 
5-33.
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To change the line-in encoding setting

The audio from line-in sources can be encoded to produce compressed or 
uncompressed audio. We recommend the following usage guidelines:

• Use Uncompressed if:

• You want optimal performance with home theaters. 
• You want to produce the highest quality sound for your multi-zone Sonos 

system (this selection requires more network bandwidth than compressed 
audio.)

• Use Compressed if:

• You are connecting more than 4 zones wirelessly.

Using the Desktop Controller software

1. From the File menu (Windows) or Sonos (Macintosh) menu, select Preferences.

2. Click the Advanced tab.

3. Select Compressed or Uncompressed from the Line-In Encoding list, and click 
OK.

Using the Sonos Controller

1. From the Music menu, select System Settings.

2. Select Advanced Settings>Line-In Encoding.

3. Use the scroll wheel to select Uncompressed or Compressed encoding, and 
touch OK. 

Note:   You will notice a delay when a line-in source is in use. When the Uncompressed 
encoding setting is selected, this delay is significantly reduced. 
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ZonePlayer Front Panel 

On/Off

• Using the Sonos Controller, 
select Pause All from the 
Zone menu.

• Using the Desktop Controller 
software, select Pause All 
from the Play menu.

Your Sonos Digital Music System is designed to be 
always on; the system uses minimal electricity when not 
playing music. To stop streaming music in all zones, use 
the Pause All feature. 

ZonePlayer status indicator 

• Flashes white when powering 
up or connecting to your 
Sonos Digital Music System.

• Solid white when powered up 
and connected to your Sonos 
Digital Music System (normal 
operation).

Indicates the current status of the ZonePlayer. When the 
ZonePlayer is in normal operation, you can turn the 
white status indicator light on and off. 

Go to "ZonePlayer Status Indicator Explanations" on A-
8for additional status indicators.
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Mute button 

• Lights solid green when sound 
is muted.

• Flashes green rapidly when 
household mute or unmute is 
about to take place.

• Flashes green slowly when 
ZonePlayer is connecting to 
your music system.

To mute/unmute this ZonePlayer: Press the Mute 
button to mute or unmute this ZonePlayer.

To mute/unmute all ZonePlayers: Press and hold the 
Mute button for 3 seconds to mute all ZonePlayers in 
your household. Press and hold for 3 seconds to unmute 
all ZonePlayers.

Volume Up (+)  
Volume Down (-)

Adjusts the volume up and down.
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ZP100 Rear Panel Connectors

Ethernet switch connectors (4) Use Category 5 Ethernet cable to connect to a router, 
computer, or additional network device such as a 
network-attached storage (NAS) device.
LED indicators:
• Green (link connection)
• Flashing Yellow (network activity)

Right speaker terminals Use high-quality speaker wire to connect the right 
speaker to the ZonePlayer.

Left speaker terminals Use high-quality speaker wire to connect the left 
speaker to the ZonePlayer.

Voltage select AC 115/230 V
Select the voltage setting that is appropriate for your 
country.

AC power (mains) input Use the supplied power cord to connect to power outlet.
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Analog audio out  
(fixed/variable)

Use a standard RCA audio cable to connect the 
ZonePlayer’s analog audio outputs to the audio inputs 
on a separate audio component, such as an amplifier or 
your home theater receiver. 

Analog audio in Use a standard RCA audio cable to connect the audio 
outputs from a separate audio component such as a CD 
player, to the ZonePlayer’s analog audio inputs. 

Subwoofer output 
Note: If you disconnect your 
subwoofer, make sure to also 
disconnect the subwoofer’s cable 
from the ZonePlayer output.

Connect a powered subwoofer to this output using a 
standard RCA cable. The system will detect when a cable 
is connected to the subwoofer output and adjust the 
crossover frequency automatically. 
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ZP80 Rear Panel Connectors

Ethernet switch connectors (2) Use Category 5 Ethernet cable to connect to a router, 
computer, or additional network device such as a 
network-attached storage (NAS) device.

AC power (mains) input  
(~100-240 V, 50-60 Hz)

Use the supplied power cord to connect to power outlet.

Analog audio in Use a standard RCA audio cable to connect the audio 
outputs from a separate audio component such as a CD 
player, to the ZonePlayer’s analog audio inputs. 

Analog audio out  
(fixed/variable)

Use a standard RCA audio cable to connect the 
ZonePlayer’s analog audio outputs to the audio inputs 
on a separate audio component, such as an amplifier or 
your home theater receiver. 
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TOSLINK™ digital audio out You can use a TOSLINK optical audio cable to connect 
the ZonePlayer’s TOSLINK digital audio output to the 
audio inputs on a separate audio component, such as an 
amplifier or your home theater receiver. 

Coaxial digital audio out You can use a digital coaxial cable to connect the 
ZonePlayer’s coaxial digital audio output to the audio 
inputs on a separate audio component, such as an 
amplifier or your home theater receiver. 
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Windows® Setup and Operation

The Desktop Controller software is compatible with Windows® 2000, Windows® XP, 
or later operating systems.

For easy setup, you should install the Desktop Controller (DCR) for Windows 
software on every Windows computer in your network that contains music files. 
However, if you wish to access music stored on a computer where file sharing is not 
enabled and the Desktop Controller software is not installed, you can go to our Web 
site at http://faq.sonos.com/sharing for assistance. 

Starting the Sonos Setup Wizard
1. Start the Sonos Desktop Controller software. Review the License Agreement and 

then click Accept. 
The Sonos Setup Wizard Welcome screen appears.

2. Click Next.

3. The Sonos Digital Music System is designed to provide you with online software 
updates. At this time you will be prompted to check for the latest software update. 
You can either check now, or check after you install the Sonos Digital Music 
System.  
Your Sonos system must be registered to receive these updates so be sure to 
register during the setup process. At no time is your e-mail address provided to 
other companies. 

4. When instructed, press the Mute and the Volume Up buttons simultaneously on 
the ZonePlayer you are connecting. (Remember, the first ZonePlayer you install 
must connect to your home network using a standard Ethernet cable). 

You can release the buttons as soon as the Mute indicator (green) and the ZonePlayer 
Status indicator (white) start to blink alternately. This takes approximately 1 second. 
Chapter 3
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Once the ZonePlayer is successfully connected, the ZonePlayer Status indicator will 
stop flashing and change to solid white (normal operation), and the Mute indicator will 
go out. If your ZonePlayer is not detected, see "ZonePlayer not detected during setup".

5. Select a name for your ZonePlayer from the list, and then click Next.

6. Choose one of the following options:

• To set up more ZonePlayers now, select Yes, I want to add more ZonePlayers, 
click Next, and repeat step 3. If you are adding a wireless ZonePlayer, you don’t 
need to connect an Ethernet cable, just a power cord. You can add additional 
wired or wireless ZonePlayers to your music system in any order. 

• If you do not wish to add more, select No, I do not wish to add more ZonePlay-
ers at this time, and click Next.

7. During the setup process, you will be asked to register your Sonos Digital Music 
System. Registering your music system allows you to receive technical support as 
well as online software updates. Sonos never gives or sells your e-mail address to 
other companies.   

8. To set up access to your music folders, select Yes, set up my music now, and click 
Next.

9. Click Add a Share.

10. Choose one of the following options:

• To add a folder stored on this computer, select Add music stored on this PC, 
and then select a folder you have music stored in (all subfolders will automatical-
ly be added) or,

• To add music stored on a different computer or a NAS device, select Add music 
stored in folders that are currently shared on my network.

• Click Browse to select a folder from the list. If the shared directory is not list-
ed, type the path name in \\name\sharename format, where name is the net-
work name for your computer or NAS device, and sharename is the name of 
the top level shared directory (for example, \\linkstation\music_share), and 
then click Next.

• If this folder is not shared anonymously, type the user name and password 
of a user with rights to access this music folder, and click Next.

• Click Finish.



Chapter 3:  Windows® Setup and Operation 3-3
11. If you purchased a Sonos Controller, you can add it to your music system now. 
Plug the Sonos Controller into the power adapter to begin charging it, and follow 
the Controller’s on-screen prompts to add it to your music system. You can use 
your Controller while it charges.

• During this process, you will be asked to press and release the Mute and the Vol-
ume Up buttons simultaneously on one of the ZonePlayers you have set up. 

12. When you see the message System is Now Setup, click the OK button. 
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Windows Desktop Controller

 

Select an action in one of the following ways:
• Click an action button; select an action from the Menu bar; highlight a selection 

and then right-click

Menu bar

Zones pane Music Library paneNow Playing pane

Playback controls

Music selection 
controls

Queue pane

Volume controls

Music queue 
controls

Get Music
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DCR Playback Controls
The Now Playing pane displays track information for the music you are currently 
listening to. You can control the music settings for the current selection using the 
playback controls below: 

 Play/Pause 

Toggles between playing and pausing the current track.

 Next/Fast Forward 

Click to jump to the start of the next track in the queue; click and hold down 
button, or click and drag progress bar to fast forward.

Previous/Rewind 

Click to move backward; click and hold down button, or click and drag 
progress bar to fast forward. 

 Shuffle 

Click to play the tracks in the music queue to play in a random order.

Repeat 

Click to repeat the queue list after the last track has finished.

Click the Get Music button to learn more about the music services available for Sonos 
customers 

Controlling the Volume (DCR)
You can control the volume for an individual zone, or for a zone group if you have 
joined more than one room together. The volume change affects the zone or zone 
group currently highlighted in the Zones pane. If you have two or more zones linked in 
a zone group, click the Equalizer button to adjust the volume for each zone 
individually.

 Volume Control

Click or drag the volume control bar to increase (+) or decrease (-) the volume. 
If a zone group is highlighted in the Zones pane, the volume change applies 
to all zones in the group. If a single zone is highlighted, the volume change 
applies to that room only.
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Equalizer 

Use to adjust the sound settings for a ZonePlayer, or to adjust volume for an 
individual zone within a zone group.

Mute

Click to mute the sound in a zone (if you have a zone group, all rooms in the 
zone group are affected).

Muting a zone or zone group (DCR)

1. From the Zones pane, click to highlight the zone you want to mute. 

2. Choose one of the following options:

• Click the Mute button. To unmute, click the Mute button again.

• From the Play menu, click Mute Zone. To unmute, click Unmute Zone.

Muting all zones (DCR)

You can temporarily mute all of your ZonePlayers at any time. The track will continue to 
progress, but there will be no sound emitted.

• To mute all the zones in your household, click Mute All Zones from the Play 
menu. 

• To unmute, click Unmute All Zones from the Play menu.

Adjusting sound settings (DCR) 

1. Highlight a zone in the Zones pane, and then click the Equalizer button  to 
change the sound settings (treble, bass, loudness, balance or volume) for an 
individual ZonePlayer. (You can also select Equalizer from the Play menu.) 

• To change the volume for a zone group, use the group volume control on the left.

• If you have two or more zones in a group, use the Equalizer window to adjust 
the volume for each zone individually. 

Managing Your Zones (DCR)
The Zones pane allows you to view the music currently playing in any zone in your 
house. You can play a different song in each zone, or you can group zones together to 
play the same music when you are having a party, or anytime you want the same 
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music selection to play in more than one room. Zones can be managed from either the 
Zones pane or the Zones menu. From either of these, you can: 

• See an alphabetical list of the zones in your house 

• Link zones together to form a zone group

• Drop a zone from a zone group

• Set clocks and alarms

• Set sleep timer

Music will continue to play while you browse your zone settings. The current zone is 
highlighted on your screen, and the music selections you make will play in that zone.

Zone Groups

A zone can be grouped together with any other zone(s) to form a zone group. This will 
cause all the zones in the zone group to play the same music in synchrony. You can link 
or drop zones from a group while the music is playing. You can also link all the 
ZonePlayers in your house with one touch by selecting All Zones-Party Mode. 

Linking a zone

You can create a zone group first and then select music to play, or you can add a room 
to a zone group where music is already playing.

1. From the Zones pane, highlight the zone you want to link to another zone or zone 
group. 

2. Choose one of the following options:

• Click Link Zone, or

• From the Zones menu, click Link Zone.

3. Select a zone to add to the group, and click OK. If you want to join all the zones in 
your house to this music queue, select All Zones-Party Mode. All of your 

Note:   Any zones you link will automatically drop their current music queue and begin to play 
the music queue from the highlighted zone. You may sometimes want to save your music 
queue as a Sonos playlist before linking a zone. See "Sonos Playlists (DCR)".
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ZonePlayers will then play the same music in synchrony until you drop the 
zones from the zone group.

Dropping a zone

1. From the Zones pane, highlight the zone group you want to change.

2. Choose one of the following options:

• Click Drop Zone, or 

• From the Zones menu, click Drop Zone. 

3. Select the zone you want to drop from the group, and click OK.

Clock and Alarms
This section discusses how to use the clock and alarms features on your Desktop 
Controller. For help using your handheld Controller, go to "Clock and Alarms".

Setting date and time

1. From the Zones menu, select Clocks and Alarms.

2. Click the Date and Time button.

3. Choose one of the following options:

• Select your time zone, desired time format, and date format, and then click OK.

• Select the Select the date and time from the Internet radio button, and then 
click OK.

• Select the Set the date and time manually radio button. Make your selections 
from the displayed fields, and then click OK.

Alarms

Adding an alarm

1. From the Zones menu, select Clocks and Alarms.

2. Click New.

Note:   The order in which you add zones makes a difference. If you select Link Zone from a 
zone where there is no music playing, any zones you link to it will also be silent.
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3. Choose the desired settings for this alarm, including the alarm time, the zone you 
would like the alarm to play in, the music source you’d like to play from, the 
frequency of the alarm, and the volume and duration settings.

If you check Include Linked Zones, the alarm will play in the zones that are linked 
together at the time the alarm goes off. It does not play in the zones that were linked 
when the alarm was originally added to the Sonos system. 

Editing an alarm

1. From the Zones pane, click to highlight the zone you want to change the alarm 
setting for.

2. From the Zones menu, select Clocks and Alarms.

3. Select the alarm you wish to change, and click Edit.

4. Make the desired changes, and click OK.

If you check Include Linked Zones, the alarm will play in the zones that are linked 
together when the alarm goes off. It does not play in the zones that were linked when 
the alarm was originally added to the Sonos system.

Deleting an alarm

1. From the Zones pane, click to highlight the zone you want delete the alarm 
setting for.

2. From the Zones menu, select Clocks and Alarms.

3. Select the alarm you wish to delete, and click Delete.

Showing the clock screen

Once an alarm has been added to your Sonos system, you can set a preference to have 
the clock screen show automatically on a handheld Controller when the alarm sounds. 

1. From the Music menu on your handheld Controller, select Clock and 
Alarms>Alarms.

2. Select the alarm from the list, and then click Advanced.

Note:   If the music you’ve selected is not available (such as an Internet radio station that has 
dropped off), your alarm will play the Sonos chime instead.To stop the chime, you can press 
Pause.
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3. Select Show Clock on this Controller. (If you want the clock to show on any other 
Controllers, repeat this process on the other Controllers.)

Setting a sleep timer 

1. From the Zones pane, click to highlight the zone or zone group you want to set up 
a sleep timer for.

2. From the Zones menu, select Sleep Timer.

3. Select the desired time frame, and then click OK.

4. If you wish to turn the sleep timer off, select Off from the list, and click OK.

When a sleep timer is active, the sleep timer icon  displays in the Now Playing 
pane.

Browsing and Playing Music (DCR)
What is your music library?

Your music library includes digital music located anywhere on your home network 
such as: 

• shared folders on your computer

• shared folders on another computer in your network

• network-attached storage (NAS) devices

The Sonos Digital Music System does not change music or playlist files created by other 
applications; these files are always treated as “read-only”.

What is a music queue?

When you make music selections, they are added to a list of tracks called a music queue. 
You can create a different music queue for each zone in your house, or you can create a 
zone group and play the same music across multiple zones. A play indicator appears to 
the left of the track currently playing in the music queue. When the current track ends, 
the next track in the queue starts to play, and play continues down through the list 
until the queue is completed. When you add tracks to a queue, you can choose to play 
them now, or add them to the end of the queue. 
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Browsing your music library 

You can browse the Music Library in various ways. You can make a broad music 
selection like play all available music by a particular artist, or make a specific selection 
like play a single track on a specified album. 

Your selection choices include:

• Artists

• Albums

• Genres

• Composers

• Tracks

• Imported Playlists

• Folders

Folders Sorting Preference

You can change the sorting preference for your music folders to sort by track name, 
track number, or filename. 

1. From the File menu, select Preferences. 

2. Click the Library tab. 

3. Select your sort order preference from the Sort By field, and click Apply or OK.

Making music selections (DCR)

Use the Music Library pane to select the music you wish to play.

 Available music sources

• Library (shared folders on your network)

• Music services, such as Rhapsody

Note:   If a computer on your network is turned off or is in standby mode, the music folders on 
that computer will be unavailable to the Sonos Digital Music System until the computer is 
turned back on. 

Note:   The music you select will play in the zone or zone group that’s highlighted in the 
Zones pane. 
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• Sonos playlists (music queues you have saved for future playback)

• Internet radio

• Line-in (external devices such as a CD player or a portable music player)

1. From the Zones pane, click to highlight the zone you want to play music in.

2. Choose one of the following options:

• From the Music Library pane, click the Library tab, or

• From the Music menu, click Music Library.

3. Use the mouse to move through the list until you reach the choice you want. To 
play all songs by an artist, on an album, or in a genre, highlight the selection and 
click Play Now to play the music now, or Add to Queue to add it to your music 
queue. Click  to expand the music tree for any selection.

You can also drag and drop selections directly from the music library to the queue. 
Highlight a selection, and while holding down the mouse, drag the selection to 
the music queue, and then release.

If you’ve previously saved music queues as Sonos playlists, you can browse these 
playlists using the Sonos Playlists tab. 

Playing music from imported playlists (DCR)

The Sonos Digital Music System is compatible with iTunes playlists as well as M3U, WPL 
and PLS playlist files created with third-party software (e.g. iTunes, WinAmp, Windows 
Media Player, etc.).

M3U, WPL and PLS support

• You can view your playlists by selecting Imported Playlists from the Library 
tab.

• If they are not visible, they are probably not located in a folder you currently have 
shared to the Sonos Digital Music System. Move the playlist file .PLS, .M3U or 
.WPL into the same music folder that you have shared to the Sonos system, up-
date your music index, and the custom playlists will appear when you select Im-
ported Playlists from the Library tab. See "Updating your music index" for 
additional information. 

Note:   You can add tracks to a music queue while listening to other music. 
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iTunes support 

• You can view your iTunes playlists in the Sonos Digital Music System by selecting 
Imported Playlists from the Library tab.

• When you make changes to your iTunes playlist(s), exit iTunes, and then update 
your Sonos music index in order to see the changes (see "Updating your music 
index")

• iTunes playlists will automatically be imported into the Imported Playlists menu 
on both the Sonos Controller and Sonos Desktop Controller (for Windows), as 
long as your 'iTunes Music Library.xml' file is shared along with your music to the 
Sonos system. For typical iTunes installations, this file is located in the iTunes 
folder.

• Sonos is unable to play tracks purchased from the iTunes Music Store as they are 
protected by Apple's proprietary Digital Rights Management (DRM) scheme. 

For additional information, browse our Frequently Asked Questions (FAQ) pages or 
Forums at http://support.sonos.com.

Music services

A music service is an online music store or online service that sells audio on a per-song, 
per audiobook, or subscription basis. If you have a music service enabled, click the 
Music Services tab to make music selections. (If you are a Rhapsody user, see 
"Selecting music from Rhapsody" for additional detail.)

If you don’t currently have a music service enabled, you can click the   button 
to browse the online music and audio services available for use with the Sonos Digital 
Music System. 

Showing/hiding the Music Services tab

You can change your preference setting to show or hide the Music Services tab in the 
Music Library pane of your Desktop Controller software. If you are not currently 
subscribed to a music service, you may wish to hide this tab. 

• Go to File>Preferences>General and check or uncheck the Show Music Ser-
vices tab in the Music Library box.  

http://support.sonos.com
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Using Rhapsody
Now you can hear more music in more rooms with Sonos and Rhapsody™, the #1 rated 
digital music service. Sonos connects directly to Rhapsody via the Web, so you don't 
have to download an application or even turn your PC on. 

Your Sonos system comes with a free 30-day Rhapsody trial. See "Creating a free 
Rhapsody trial account" for more information.

Rhapsody subscribers can simply click the Music Services tab in the Music Library to 
browse and select Rhapsody content. See "Selecting music from Rhapsody" for 
additional information.

Configuring Rhapsody

Creating a free Rhapsody trial account

Your Sonos system comes with a free Rhapsody trial—no signup, no credit card 
necessary. If you did not activate a free Rhapsody trial account while setting up your 
Sonos Digital Music System, you can do it now (your Sonos system must be registered.) 

1. Select File>Preferences.

2. From the Accounts tab, select Add.

Note:   If your music service does not appear when you click the Music Services tab, your 
firewall may be preventing Sonos from accessing it. See "Firewall Information" or go to http://
faq.sonos.com/firewall for additional information. 

Note:   Rhapsody may not be available in your country. If the Rhapsody trial does not appear 
as an option, please click the Get Music button for more details.

http://faq.sonos.com/firewall
http://faq.sonos.com/firewall
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3. Select Rhapsody Trial from the list of Account types.

4. A username and password will be automatically assigned for you. Click OK.

Your free Rhapsody trial account will be valid for 30 days. After that, if you wish to 
become a subscriber, go to www.sonos.com/rhapsody for additional information. 
Once your Rhapsody account is set up, simply add the account information to Sonos in 
order to access Rhapsody from your Sonos Digital Music System (see "Adding your 
Rhapsody account to Sonos".) 

Current Rhapsody users who have recently updated to Sonos 2.0

If you are an existing Rhapsody customer, prior to Sonos version 2.0 your computer 
had to be on in order to access your Rhapsody content (the Rhapsody client on your 
computer accessed the Rhapsody server via UPnP.)

To take advantage of accessing Rhapsody via the Web, simply add your Rhapsody 
account to Sonos ("Adding your Rhapsody account to Sonos").

Adding your Rhapsody account to Sonos

If you have a Rhapsody account, simply add the account information to Sonos and 
you’ll have instant access to Rhapsody from the Sonos Digital Music System.

1. Add your Rhapsody account information to Sonos by selecting 
File>Preferences>Accounts>Add.

2. Select Rhapsody from the list of Account types.

3. Enter your Rhapsody username and password and click OK.

4. If you previously had a Rhapsody trial account in place, you will be asked if you 
want to merge the information from your trial account into the new account. If 
you select Yes, any playlists and content selections you saved to My Rhapsody 
Library will be preserved under the new account. 

5. Update your music index whenever you add new content by selecting Update 
Music Index Now from the Music menu. Or you can schedule daily music index 
updates (see "Scheduling music index updates".) 

Using Rhapsody with UPnP

If you are using Rhapsody’s desktop application to organize the music on your local 
drive, your Sonos system can access Rhapsody’s server using Universal Plug and Play 
(UPnP). You should only use this method to access Rhapsody if you are using 

http://www.sonos.com/rhapsody
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Rhapsody’s desktop application, or if you have multiple Rhapsody accounts active in 
your household. Otherwise simply add your Rhapsody account information to 
Sonos— see "Adding your Rhapsody account to Sonos".

To access Rhapsody’s server using UPnP, make sure UPnP is enabled in the Rhapsody 
desktop application so that the Sonos Digital Music System can recognize it and show 
Rhapsody in your Music Library. This is a one-time preference setting. Remember— 
your computer must be on in order to stream Rhapsody content if you are accessing 
Rhapsody’s server this way.

Rhapsody setting:

1. Start RealRhapsody.

2. Click Tools>Preferences>Rhapsody Server (UPnP).

3. Click to check the Start UPnP Server Once Logged In box, and then click Start.

4. Click OK.

Sonos setting:

1. From the Sonos Desktop Controller for Windows, select File>Preferences and 
click the Advanced Options button.

2. Check the Show music from Rhapsody UPnP servers checkbox and click OK. 

Selecting music from Rhapsody

Music selection choices include: 

• Rhapsody Music Guide

• Rhapsody Radio

• My Artists

• My Albums

• My Genres

• My Tracks

• My Playlists

1. From the Music Library pane, click the Music Services tab, and select Rhapsody. 

• If the Music Services tab is not displayed in the Music Library, see "Showing/hid-
ing the Music Services tab".
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2. Highlight a music selection, and click Play Now, Play Next, or Add to Queue to 
add it to the end of your music queue. If you are selecting music from the 
Rhapsody Music Guide, you can additionally select Add To My Rhapsody Library.

Rhapsody Music Guide

The Rhapsody Music Guide displays a variety of music selections, including a list of 
music genres, top artists, top albums, and top tracks, new releases and Rhapsody-
recommended selections. Click any of the links to browse through the Rhapsody Music 
Guide and make selections.

Rhapsody Radio

1. Select a zone.

2. Click the Music Services tab.

3. Select Rhapsody Radio, and then select a radio station from the My Stations list.

4. Click Play Now.

Changing your Rhapsody password

If you want to change your Rhapsody password, you must first change it in 
Rhapsody. Go to www.rhapsody.com and select My Account, or if you have 
downloaded the Rhapsody desktop client, you can change from the My Account 
menu.

Once you've changed your password within Rhapsody, you can update the Sonos 
system with the new Rhapsody password using this Accounts>Edit option. 

Deleting a Rhapsody account from Sonos

1. From the Desktop Controller menu bar, select File>Preferences.

2. Select the Accounts tab.

3. Select the account you wish to remove, and click Remove.

4. Click Yes to confirm, and then click OK. 

This will not delete your account from Rhapsody. Your account status with Rhapsody 
will be unaffected.

Note:   If you don’t change your password within Rhapsody first, it won’t work on your Sonos 
Digital Music System.

http://www.rhapsody.com/
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Using Audible
The Sonos Digital Music System is compatible with Audible, Inc. (Format 4 file 
downloads only.) If you are interested in signing up for Audible’s spoken word audio 
services, go to http://www.audible.com for more information.

Adding Audible to your Sonos System

If you have AudibleManager software installed on your computer, the Sonos Digital 
Music System detects it when you add a music folder to your Sonos system. When 
Audible is detected, a third radio button displays on the Select Music Source screen. 

1. Select Add my Audible books, and click Next.

2. Click Next to share the folder.

3. Enter your Audible account username and password, and click OK.

If you don’t have AudibleManager installed

1. Make sure your Audible files are in a folder that you have shared to the Sonos 
Digital Music System (using the Select Music Source screen).

2. Add your Audible account information to Sonos by selecting 
File>Preferences>Accounts>Add.

3. Select Audible as the Account Type.

4. Enter your Audible username and password and click OK.

http://www.audible.com
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5. Reindex your music library whenever you add new content by selecting Update 
Music Index Now from the Music menu.

Adding an additional Audible account to Sonos

1. From the Desktop Controller menu bar, select File>Preferences.

2. Select the Accounts tab, and click Add.

3. Select Audible as the Account Type.

4. Enter your Audible username and password and click OKAdd.

Deleting an Audible account from Sonos

1. From the Desktop Controller menu bar, select File>Preferences.

2. Select the Accounts tab, and click Remove.

3. Enter your Audible password for verification, and click OK.

When listening to a book, you can use the Next and Previous keys to move from 
chapter to chapter. 

It’s easy to view your Audible files by genre. From the Music Library, select 
Library>Genres, and select Audiobooks.

Other content, such as journals will appear in the Spokenword genre. You may need to 
select All to view your journal content.
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Managing Your Music Queue (DCR) 
Once you have added tracks to a queue, you can make changes to the music queue 
using the playback buttons, the Play menu options, or the queue control buttons. You 
can:

• Remove a track from the queue

• Clear the entire music queue

• Move a track within the queue

• Click the Shuffle button to play the tracks in the music queue in a random order

• Click the Repeat button to repeat the music queue after the last track has fin-
ished 

• Save a queue as a Sonos playlist

Removing a track from the queue

1. From the Queue pane, click to highlight the song you want to remove from the 
music queue.

2. Choose one of the following options:

• Click Remove Track, or 

• Select Queue>Remove Track from the Play menu.

The track disappears from the queue list.

Moving a track within the queue

1. Click the left-mouse button and, while holding, drag the track you want to move 
within the queue.

2. Drag it up or down to the desired location, and then release.

Clearing the music queue

1. Choose one of the following options:

• Click Clear Queue from the bottom of the Queue pane, or 

• Click Queue>Clear Queue from the Play menu.

2. Click Yes to confirm.

This will clear the entire queue and stop the music from playing.

Changing the play mode
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1. Click the Shuffle or Repeat buttons displayed in the Now Playing pane to 
change the play mode. 

The selected play mode appears as an icon in the Now Playing pane. 

 Shuffle 

 Repeat

 Shuffle/Repeat

Sonos Playlists (DCR) 
Sonos Playlists are music queues you create and save for future listening. For example, 
you might want to create a jazz playlist, a party playlist, or an easy listening playlist. 

Creating a Sonos Playlist

1. Create a music queue by selecting music tracks from your music library. 

2. Choose one of the following options:

• From the Queue pane, click Save Queue, or 

• Click Queue>Save Queue as Sonos Playlist from the Play menu.

3. Type a name for this playlist, and click OK. This queue is now accessible from the 
Sonos Playlists tab.

4. To play a saved queue, click the desired playlist from the Sonos Playlists tab and 
click Play Now to start the playlist immediately, or Add to Queue to add it to the 
end of your current music queue.
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Deleting a Sonos Playlist

1. From the Sonos Playlists tab, highlight the playlist you want to delete.

2. Choose one of the following options:

• Click Delete, or 

• Click Delete Playlist from the Music menu.

Renaming a Sonos Playlist

1. From the Sonos Playlists tab, highlight the playlist you want to rename.

2. Choose one of the following options:

• Right-click and select Rename Playlist, or 

• Click Rename Playlist from the Music menu.

Internet Radio (DCR)
The Radio tab provides a list of third-party streaming broadcasts for you to select from. 
If you have a music service enabled on your computer, you can make radio station 
selections from the music service as well.

• Use the Radio tab to display and select from a Sonos-supplied list of streaming 
MP3 or WMA broadcasts. You can make changes to this list using both the Desk-
top Controller software and your Controller.

• Use the Music Services tab to display and select radio stations from your music 
service, if you have one enabled. 

Playing an Internet radio stationPlaying an Internet radio station

1. Select the zone you want to listen in.

2. Click the Radio tab.

3. Select a radio station from the list.

4. Click Play Now.

Setting your Internet radio preferenceSetting your Internet radio preferences

You can receive radio station updates automatically whenever Sonos releases a new 
list. Your music system must be registered in order to receive updates. If you have not 
yet registered, see "System Registration".

1. From the File menu, select Preferences.
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2. Click the Updates tab.

3. Select the desired setting from the Internet Radio Station Updates section, and 
click OK.

Adding a radio station

You can add a radio station that does not appear in your Sonos-supplied list. You must 
know the streaming URL, and the station must use the streaming MP3 broadcast 
format. This station will be added to your Favorites list.

1. Click the Radio tab. 

2. Choose one of the following options:

• Click Add New, or 

• Click Add New Internet Radio Station from the Music menu.

3. Type the streaming URL for the radio station you want to add to your station list 
(for example: http://shoutcast.com/sbin/shoutcast-
playlists.pls?rn=8107&file=filename.pls). 

4. Type the radio station’s name in the Station Name field, and click OK.

The new radio station gets added to your Favorites list, not to the Sonos-supplied 
Internet radio station list.

Editing a radio station

1. Click the Radio tab. 

2. Click to highlight an Internet radio station, and then click Edit.

3. Change the streaming URL, the station name, or click Add to Favorites to add the 
station to your Favorites list, and click OK.

Note:   You can edit the streaming URL or station name only for the radio stations that are in 
your Favorites list. However you can add any radio station to your Favorite Stations list using 
the Edit option. 
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Your “Favorites” list

Adding a station to your Favorite Stations list

When you add radio stations to your Favorite Stations list, they are duplicated in your 
Favorites folder, not moved from the original Internet radio list. Highlight a station from 
the Internet radio list, and click Add to Favorites.

Deleting a station from your Favorite Stations list

From the Radio tab, highlight the station you want to delete from your Favorite 
Stations list and then click Delete. 

Managing Music Folders (DCR)
The Sonos Digital Music System can play music from any networked computer or 
network-attached storage (NAS) device where you have shared music folders. During 
the setup process, you are guided through the process of accessing your shared music 
folders. Over time, you may wish to add or remove music folders from this list.

These music folders are indexed by the Sonos Digital Music System so that you can 
view your music by categories. If you add new music to a folder that is already indexed, 
you can update your music index to add this music to your library. 

To play music from imported playlists, simply drop the playlist file .PLS, .M3U or .WPL 
into the same music folder that you have shared to the Sonos system, re-index the 
share and the custom playlists will appear when you select Imported Playlists from 
the Music menu.

Adding a shared folder

1. From the Music menu, select Music Library Setup.

The shared music folders that are currently available to your Sonos Digital Music 
System appear. 

2. Click Add a Share.

3. To add music that is stored on this computer, select Add music stored on this PC, 
and click Next.

a. Click to highlight a music folder, and then click Next.

b. Click Next to confirm.

c. Click Finish.
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4. To add music stored on a remote computer or a NAS device, select Add music 
stored in folders that are currently shared on my network.

a. Type the network path for the music folder (\\Name\Sharename, where 
Name is the network name for your computer or NAS device, and 
Sharename is the name of the top level shared folder, or click Browse to 
search for it.

b. If it is not shared anonymously, enter the user name and password of a user 
with permission to access this folder, and click Next.

c. Click OK to confirm.

d. Click Finish.

Removing a shared folder

1. From the Music Library Setup screen, highlight the share you want to remove 
from the list, and click Remove. 

2. Click Yes to confirm.

Updating your music index

If you add new music to a music folder that is already indexed, you can update your 
music index in order to add this music to your library. 

1. From the Music menu, select Update Music Index Now.

2. Click Yes to confirm.

3. The message, “Updating Music Index” appears at the bottom of the screen. When 
the update is complete, the message “Ready” appears. 

Resetting music library permissions

Some music services may automatically change the permissions on your music folders 
when you add new music, so that Sonos can no longer access your music. If your music 
service does this, you can change the preference setting below to allow Sonos to reset 
permissions when your music index is updated. You should not set this preference 
unless you need to, as it takes longer to update your music index when this box is 
checked.

1. From the File menu, select Preferences.

2. Click the Advanced tab.
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3. Check the Fix Permissions when updating the music index on this computer 
box, and click OK. 

Scheduling music index updates

You can set your music system to automatically update your music index at the same 
time each day. 

1. From the Music menu, select Schedule Music Index Updates.

2. Select the time you would like your music index to automatically update, and click 
OK.

Software Updates (DCR)
Sonos provides software updates for your music system in order to improve 
performance and add features. Your music system must be registered in order to 
receive these software updates. If you have not yet registered, see "System 
Registration". 

There are two options available: 

• Periodically check for updates. An alert will appear when you start the Desktop 
Controller software indicating there are updates available. 

• Do not check for updates.

Setting software update preferences

1. From the File menu, select Preferences.

2. Click the Updates tab.

3. Select the desired setting from the Software Update Notifications section, and 
click OK.

Downloading software updates

1. From the Help menu, select Check for Updates. 

2. If there are updates available, click Update Now to download.

• Your ZonePlayers as well as your Desktop Controller software will be updat-
ed as Sonos components must carry the same software version number. This 
process may take several minutes per device, depending upon your network 
connection. Your Sonos Desktop Controller software will automatically 
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close and then re-open during the update process. 

• Software updates to your handheld Sonos Controller are initiated from that de-
vice, so if you have updated your DCR, you will be prompted to update your 
Controller the next time you use it. Simply follow the Controller’s on-screen 
prompts.

• If your software is up to date, the message “Your Sonos Digital Music System is 
up to date. No updates are required” will appear instead.

ZonePlayer software updates

One or more ZonePlayers may need to be updated when you purchase a new 
ZonePlayer with a later software version, or if you plug in a ZonePlayer that was not in 
use when you performed your last software update. When a ZonePlayer’s software 
version gets out of sync from the rest of your Sonos Digital Music System components, 
you will see the following message displayed in the Zones pane:

Click the outdated zone to begin the software update process.

Additional Preferences (DCR)
In addition to selecting your Internet radio ("Setting your Internet radio 
preferenceSetting your Internet radio preferences") and software update preferences 
("Setting software update preferences"), you can also change your wireless channel, 
and line-in encoding preferences.

Caution:  Do not disconnect power from your ZonePlayer(s), or in any way disable your 
Sonos Digital Music System while this process is running. Contact Sonos Customer 
Support if an error occurs.
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Selecting a different wireless channel (DCR)

The Sonos Digital Music System selects the optimal radio frequency channel during 
setup. However, if you have other wireless devices using this channel, you may want to 
switch the Sonos Digital Music System to another channel to avoid conflicts, as 
conflicts may cause audio drop-outs.

1. From the File menu, select Preferences.

2. Click the Advanced tab.

3. Select another wireless channel from the Wireless Channel drop-down list, and 
click OK.

It may take several seconds for the switch to take effect. If you have music playing, a 
short music dropout will occur during the wireless channel change.

Line-in encoding (DCR)

The audio from line-in sources can be encoded to produce compressed or 
uncompressed audio. We recommend the following usage guidelines:

• Use Uncompressed if:

• You want optimal performance with home theaters. 
• You want to produce the highest quality sound for your multi-zone Sonos 

system (this selection requires more network bandwidth than compressed 
audio.)

• Use Compressed if:

• You are connecting more than 4 zones wirelessly.
1. From the File menu, select Preferences.

2. Click the Advanced tab.

3. Select Compressed or Uncompressed from the Line-In Encoding list, and click 
OK. 

When Compressed is selected, you will notice a delay before the music starts to play. 
When Uncompressed is selected, this delay is significantly reduced. 

Resetting Your DCR
If you want to join your computer to a different Sonos Digital Music System, you must 
first reset your Desktop Controller. 
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1. Select Reset Desktop Controller from the Help menu. 

2. Click Yes.

Your Desktop Controller window will automatically close. The next time you start the 
Desktop Controller software, the Setup Wizard will appear to prompt you through the 
setup process. If you are joining your computer to an existing Sonos Digital Music 
System, you do not have to press the Mute and Volume Up buttons on every 
ZonePlayer again - just one that is connected to your system via an Ethernet cable. 

Firewall Information
 

The Sonos Digital Music System is designed to work with existing firewall software. 
Follow the links below for information on the specific firewall software you are using.

"Microsoft XP firewall"

"Zone Alarm (free version)"

"Zone Alarm Pro"

"McAfee Personal Firewall Plus"

"Norton Personal Firewall"

"ISS Black Ice Protection"

If your software firewall is not listed, please see   http://faq.sonos.com/firewall for the 
latest firewall information or contact Sonos Technical Support at http://
www.sonos.com/support.

Microsoft XP firewall

1. When installing the Sonos Desktop Controller, select Unblock in the Windows 
Firewall.

2.  If the dialog box does not appear, go to Start>Settings>Control Panel.

3. Click Security Center>Windows Firewall.

4. Click the Exceptions tab. 

5. Make sure Sonos Application has a check mark next to it. 

http://faq.sonos.com/firewall
http://www.sonos.com/support
http://www.sonos.com/support
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6. If you don’t see Sonos Application and you have already installed the Sonos 
Desktop Controller, click the Add Program button and browse until you find 
Sonos Application.

7. Click to highlight, and then click OK.

Zone Alarm (free version)

1. Display the Firewall settings screen.

1. From the Main tab, check to make sure the Trusted Zones Security is set to Medium 
(default setting) level security, and the Net BIOS ports are open (default).

2. Click the Zones tab, and verify that the network the Sonos Zone Player resides on 
is set to Trusted. 

3. From the Program Control screen, make sure the Sonos Desktop Controller 
(Sonos.exe) application is allowed full access to the Internet/Network. 

4. When launching the Sonos Desktop Controller, select Remember this Setting 
and click Allow.

Zone Alarm Pro

1. Display the Firewall settings screen.

1. From the Main tab, check to make sure the Trusted Zones Security is set to Medium 
(default setting) level security. 

2. From the Program Control screen, make sure the Sonos Desktop Controller 
(Sonos.exe) application is allowed full access to the Internet/Network. 

3. When launching the Sonos Desktop Controller, select Remember this Setting 
and click Allow.

Note:   The Sonos Digital Music System will not operate correctly if the Trusted Zone is set to 
"High" and if NetBIOS ports are blocked.

Note:   The Sonos Digital Music System will not operate correctly if the Trusted Zone is set to 
High, and if NetBIOS ports are blocked.
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McAfee Personal Firewall Plus

4. When the Sonos Application requests access to the Internet, select Grant 
Access.Select a security level from the Security Settings tab. The Sonos Digital 
Music System is compatible with all McAfee Personal Firewall configurations 
except Lockdown.

5. From the Internet Applications tab, make sure that the Sonos Application is set 
to Allow Full Access.

If the above configuration does NOT let the Sonos Digital Music System operate 
correctly, you can try changing the firewall settings to allow access to your music and 
your ZonePlayers. 

• Open the firewall by double-clicking the icon in the system tray - typically in the 
bottom right corner of your screen. 

• Select Utilities in the System Services.

• Put a check mark in the box next to Microsoft Directory Server Port 445.

• Put a check mark in the box next to Universal Plug and Play (UPNP) Port 5000.

• Select OK.

Norton Personal Firewall

The Norton Personal Firewall is fully compatible with the Sonos Digital Music System. 
Follow the steps below to configure your firewall:

1. Make sure the Sonos Desktop Controller is allowed full access on all ports (when 
asked) by selecting Always allow connections in this program on all ports.

2. Select Permit from the What do you want to do drop-down when sonos.exe 
attempts to access the Internet.

3. Allow sonos.exe to connect to a DNS server by selecting Always allow 
connections in this program on all ports.

4. From the Firewall tab, select a firewall level. The Sonos Digital Music System is 
compatible with any Internet Security setting you choose, from High to Off.

5. From the Programs tab, make sure that sonos.exe is set to Permit All. 

For Professional Firewall users, all of the following settings must be changed on the 
Advanced selections screen:
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• Scroll to Default Inbound NetBIOS Name, click Modify, click Permit, then click 
OK.

• Scroll to Default Block MS Windows 2000 SMB, click Modify, click Permit, 
then click OK.

• Scroll to Block Windows File Sharing, click Modify, click Permit, then click OK.

• Scroll to Inbound UDP, click Modify, click Permit, then click OK.

• Click OK to exit the Advanced Firewall selections screen. 

ISS Black Ice Protection

If you are running Black Ice Protection, be sure to allow the Sonos Desktop Controller 
(Sonos.exe) full access to the Internet and Network.

Black Ice Protection by Internet Security Systems is fully compatible with the Sonos 
Digital Music System. Your music system will operate seamlessly if you select either the 
"Cautious" or "Trusting" protection level from the Firewall tab. 

If you cannot access your music and Sonos Desktop Controller software after setting 
the Protection Level to Cautious or Trusting, please follow the instructions below:

1. Select the Intruders or Events tab.

2. Identify the ZonePlayer’s IP address.

3. Right-click and select Trust Intruder>Trust and Accept. 

This setting will allow the Sonos Digital Music System accessibility with all firewall 
security settings; Trusting, Cautious, Nervous, and Paranoid.

Note:   The Sonos Digital Music System will NOT function correctly if "Block Traffic" is enabled



Macintosh OS X® Setup and 
Operation

The Desktop Controller software is compatible with Macintosh OS X, version 10.3 or 
later.

For easy setup, you should install the Desktop Controller (DCR) for Macintosh software 
on every Macintosh computer in your network that contains music files. However, if 
you wish to access music stored on a computer where file sharing is not enabled and 
the Desktop Controller software is not installed, you can go to our Web site at http://
faq.sonos.com/sharing for assistance. 

Starting Sonos Setup Assistant
1. Open the Sonos Desktop Controller software. Review the License Agreement, and 

then select Accept.

The Sonos Setup Assistant Welcome screen appears.

2. Select Continue.

3. The Sonos Digital Music System is designed to provide you with online software 
updates. At this time you will be prompted to check for the latest software update. 
You can either check now, or check after you install the Sonos Digital Music 
System.  
Your Sonos system must be registered to receive these updates so be sure to 
register during the setup process when you are asked. At no time is your e-mail 
address provided to other companies. 
Chapter 4
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4. When instructed, press the Mute and the Volume Up buttons simultaneously on 
the ZonePlayer you are connecting. (Remember, the first ZonePlayer you install 
must connect to your home network using a standard Ethernet cable). 

You can release the buttons as soon as the Mute indicator (green) and the ZonePlayer 
Status Indicator light (white) start to blink alternately. This takes approximately 1 
second. Once the ZonePlayer is successfully connected, the ZonePlayer Status 
Indicator light will stop flashing and change to solid white (normal operation), and the 
Mute indicator will go out. 

During the setup process, you may be asked to configure your Macintosh’s firewall. See 
’Firewall Information’ for help with this step.

5. Choose a ZonePlayer name from the pop-up menu, and then select Continue. 

6. Choose one of the following options:

• If you have another ZonePlayer to set up now, choose Yes, I want to add anoth-
er ZonePlayer and select Continue. 

• If you don’t want to set up another ZonePlayer, choose I do not want to add an-
other ZonePlayer at this time, and select Continue.

7. When you are prompted to set up access to your music folders, choose Yes, set up 
my music now, and select Continue.

Where is your music stored?

• Depending upon where your music is stored, you may be asked to provide an 
admistrator name and password to allow access to your music folders. 

• If your Macintosh computer does not have Windows Sharing enabled, the Desk-
top Controller software will guide you through the process of enabling it. Your 
music files are never copied from their current locations - your folders are simply 
shared so they can be accessed by your Sonos Digital Music System.
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When you are prompted to set up access to your music folders, choose Yes, set up my 
music now, and select Continue.

 

Once setup is complete, if you purchased a Sonos Controller you can add it to your 
music system now. 

1. Plug your Sonos Controller into the AC power adapter and follow the on-screen 
prompts to add the Controller to your music system. You can use your Controller 
while it charges.

2. When you see the message Setup Complete, touch the OK button.

Note:   Firewall software such as OS X Firewall, Norton Personal Firewall for Macintosh, or 
Intego NetBarrier can block the operation of your Sonos Desktop Controller software. During 
installation, you may see prompts from your firewall software indicating that the Sonos 
application is attempting to perform certain operations. You should always allow full access 
to the Sonos application. You may also be asked to change the settings of your firewall 
software to ensure that Windows file sharing is not blocked. See ’Firewall Information’ or go to 
our Web site at http://faq.sonos.com/firewall for the latest firewall information.

To add music stored in your Music folder, select In my Music folder, and select Continue. 
Click the Lock icon to enter your administrator password. If your computer does not 
currently allow Windows Sharing, you will be prompted to enable it. 
If you have used iTunes Preferences to change where you store iTunes music, this option 
will appear as In my iTunes Music folder instead.

To add music stored elsewhere on your computer, select On my computer or an external 
drive connected to my computer, and select Continue. Select Browse to choose a 
folder, and then select Continue.

To add music stored on a different computer or a NAS device, select On a networked 
device such as a network-attached storage (NAS) device on my network, and select 
Continue. Type the path name (\\Name\Sharename, where Name is the network name for 
a computer or NAS device, and Sharename is the name of the top level shared folder.) If 
this folder is not shared anonymously, type the user name and password of a user with 
permission to access this music folder. 

http://faq.sonos.com/firewall 
http://faq.sonos.com/firewall 
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Macintosh Desktop Controller

Select an action in one of the following ways:
• Select a button

• Select an action from the menu bar

Menu bar

Zones pane Music Library paneNow Playing pane

Playback controls

Music queue 
controls

Music selection 
controls

Queue pane

Volume controls

Show/hide 
Music Library

Get 
music
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DCR Playback Controls
Play/Pause 

Toggles between playing and pausing the current track.

Next/Fast Forward 

Select to jump to the start of the next track in the queue; select and hold 
down button, or select and drag progress bar to fast forward.

Previous/Rewind 

Select to move backward; select and hold down button, or select and drag 
progress bar to rewind. 

 Shuffle 

Select to play the tracks in the music queue in a random order.

Repeat 

Select to repeat the queue list after the last track has finished.

Click the Get Music button to learn more about the music services available for Sonos 
customers  

Controlling the Volume (DCR)
You can control the volume for an individual zone, or for a zone group. If you have two 
or more zones linked in a zone group, select the Equalizer button or select Equalizer 
from the Play menu to adjust the volume for each zone individually.

Volume Control

Select or drag the volume control bar to increase (+) or decrease (-) the 
volume. If a zone group is selected in the Zones pane, the volume change 
applies to all zones in the group. If a single zone is selected, the volume 
change applies to that room only.

Equalizer 

Use to adjust the sound settings for a ZonePlayer, or to adjust volume for an 
individual zone within a zone group.
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Mute

Select to mute the sound in a zone (if you have a zone group, all rooms in the 
zone group are affected). Select again to unmute.

Muting all zones (DCR)

• To mute all the ZonePlayers in your household, select Mute All Zones from the 
Play menu. The track will continue to progress, but no sound will be emitted.

• To unmute all, select Unmute All Zones from the Play menu.

Adjusting sound settings (DCR) 

1. Highlight a zone in the Zones pane and select the Equalizer button  to 
change the sound settings (treble, bass, loudness, balance, or volume) for an 
individual ZonePlayer. (You can also select Equalizer from the Play menu.) 

• When changing the volume for a zone group, use the group volume control on 
the left.

• If you have two or more zones in a group, use the Equalizer panel to adjust the 
volume for each zone individually. 

Managing Your Zones (DCR)
You can play a different music selection in each zone, or you can group zones together 
to play the same music in synchrony. Zones can be managed from either the Zones 
pane or the Zones menu. From either of these, you can: 

• See an alphabetical list of the zones in your house 

• Link zones together to form a zone group

• Drop a zone from a zone group

Music will continue to play while you browse your zone settings. The current zone is 
highlighted, and the music selections you make will play in that zone.

Zone groups 

Group a zone with any other zone(s) to form a zone group, causing those zones to play 
the same music in synchrony. You can link or drop zones from a group while the music 
is playing. Link all ZonePlayers by selecting All Zones-Party Mode. 
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Linking a zone

You can create a zone group first and then select music to play, or you can add a room 
to a zone group where music is already playing.

1. From the Zones pane, select the zone you want to link another zone or zone 
group to, and select Link Zone. 

2. Select a zone to add to the group, and select Link. To join all zones, select All 
Zones-Party Mode. 

Dropping a zone

1. From the Zones pane, select the zone group you want to change, and select Drop 
Zone. 

2. Select the zone you want to drop from the group, and select Drop.

Clock and Alarms
This section discusses how to use the clock and alarms features on your Desktop 
Controller. For help using your handheld Controller, go to ’Clock and Alarms’.

Setting date and time

1. From the Zones pane, click to highlight the zone you want to set the date and 
time for.

2. From the Zones menu, select Clocks and Alarms.

3. Click the Date and Time button.

4. Choose one of the following options:

• Select your time zone, desired time format, and date format, and then click Set.

• Select the Select the date and time from the Internet radio button, and then 
click Set.

Note:   Any zones you link will automatically drop their current music queue and begin to play 
the music queue from the zone group. You may want to save your music queue as a Sonos 
playlist before linking a zone. See ’Sonos Playlists (DCR)’.

Note:   The order in which you add zones makes a difference. If you select Link Zone from a 
zone where there is no music playing, any zones you link to it will also be silent. 
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• Select the Set the date and time manually radio button. Make your selections 
from the displayed fields, and then click Set.

Alarms

Adding an alarm

1. From the Zones menu, select Clocks and Alarms.

2. Click New.

3. Choose the desired settings for this alarm, including the alarm time, the zone you 
would like the alarm to play in, the music source you’d like to play from, the 
frequency of the alarm, and the volume and duration settings.

If you check Include Linked Zones, the alarm will play in the zones that are linked 
together at the time the alarm goes off. It does not play in the zones that were linked 
when the alarm was originally added to the Sonos system.  

Editing an alarm

1. From the Zones pane, click to highlight the zone you want to change the alarm 
setting for.

2. From the Zones menu, select Clocks and Alarms.

3. Select the alarm you wish to change, and click Edit.

4. Make the desired changes, and then click Save.

If you check Include Linked Zones, the alarm will play in the zones that are linked 
together when the alarm goes off. It does not play in the zones that were linked when 
the alarm was originally added to the Sonos system.

Deleting an alarm

1. From the Zones pane, click to highlight the zone you want delete the alarm 
setting for.

2. From the Zones menu, select Clocks and Alarms.

3. Select the alarm you wish to delete, and click Delete.

Note:   If the music you’ve selected is not available (such as an Internet radio station 
that has dropped off), your alarm will play the Sonos chime instead. To stop the 
chime, you can press Pause.
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Showing the clock screen

Once an alarm has been added to your Sonos system, you can set a preference to have 
the clock screen show automatically on a handheld Controller when the alarm sounds. 

1. From the Music menu on your handheld Controller, select Clock and 
Alarms>Alarms.

2. Select the alarm from the list, and then click Advanced.

3. Select Show Clock on this Controller. (If you want the clock to show on any other 
Controllers, repeat this process on the other Controllers.)

Setting a sleep timer 

1. From the Zones pane, click to highlight the zone or zone group you want to set up 
a sleep timer for.

2. From the Zones menu, select Sleep Timer.

3. Select the desired time frame, and then click OK.

4. If you wish to turn the sleep timer off, select Off from the list, and click OK.

When a sleep timer is active, the sleep timer icon  displays in the Now Playing 
pane.

Browsing and Playing Music (DCR)
What is your music library?

Your music library includes digital music located anywhere on your home network 
such as: 

• shared folders on your computer

• shared folders on another computer in your network

• network-attached storage (NAS) devices

The Sonos Digital Music System does not change music or playlist files created by other 
applications; these files are always treated as read-only.

What is a music queue?

When you make music selections, they are added to a list of tracks called a music queue. 
You can create a different music queue for each zone in your house, or you can create a 
zone group and play the same music across multiple zones. A play indicator appears to 
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the left of the track currently playing in the music queue. When you add tracks to a 
queue, you can choose to play them now, play them next, or place them at the end of 
the queue. 

Browsing your music library 
 

Your selection choices include:

• Artists

• Albums

• Genres

• Composers

• Tracks

• Imported Playlists

• (The Sonos Digital Music System is compatible with iTunes playlists, as well 
as M3U, WPL and PLS playlist files created with third-party software such as 
WinAmp or Windows Media Player.) 

• Folders

Making music selections (DCR)

Use the Music Library pane to select the music you wish to play.

Available music sources

• Library (shared folders on your network)

• Music services, such as Rhapsody 

• Sonos playlists (music queues you have saved for future playback)

• Internet radio

• Line-In (external audio components such as a CD player or a portable music 

Note:   If a computer on your network is turned off or is in sleep mode, the music on 
that computer will be unavailable to the Sonos Digital Music System until the 
computer is turned back on. 

Note:   The music you select will play in the zone or zone group that’s selected in the Zones 
pane. 
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player)

1. From the Zones pane, select the zone you want to play music in. 

2. Choose one of the following options:

• From the Music Library pane, select the Library tab, or 

• From the Music menu, select Library.

3. To play all songs by an artist, on an album, or in a genre, select what you’d like to 
play, and then select Play Now to play the music now, or Add to Queue to add it 
to your music queue. Select  to expand the music outline for any selection.

You can also drag and drop selections directly from the music library to the queue. 
Highlight a selection, and while holding down the mouse, drag the selection to the 
music queue, and then release

If you’ve previously saved music queues as Sonos playlists, you can browse these 
playlists using the Sonos Playlists tab. 

Music services

If you have a music service enabled, click the Music Services tab to make music 
selections. (If you are a Rhapsody user, see ’Selecting music from Rhapsody’ for 
additional detail.)

If you don’t currently have a music service enabled, you can click the   button 
to browse the online music and audio services available for use with the Sonos Digital 
Music System. 

Showing/hiding the Music Services tab

 If you have a music service enabled on a PC in your network, you can select music from 
this service on your Macintosh computer. Simply add the Music Services tab to your 
Music Library. If you are not currently subscribed to a music service, you may wish to 
keep this tab hidden. 

• To change your preference setting, go to Sonos>Preferences>General and 
check or uncheck the Show Music Services tab in the Music Library box. 

• If you want Sonos to alert you when a compatible music service is found, check 

Note:   You can add tracks to a music queue while listening to other music. 
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the Offer to show... box. 

Playing music from imported playlists (DCR)

The Sonos Digital Music System is compatible with iTunes playlists as well as M3U, WPL 
and PLS playlist files created with third-party software (e.g. iTunes, WinAmp, Windows 
Media Player, etc.).

M3U, WPL and PLS support

• You can view your playlists by selecting Imported Playlists within the Library 
tab.

• If they are not visible, they are probably not located in a folder you currently have 
shared to the Sonos Digital Music System. Move the playlist file .PLS, .M3U or 
.WPL into the same music folder that you have shared to the Sonos system, up-
date your music index, and the custom playlists will appear when you select Im-
ported Playlists within the Library tab. See ’Updating your music index’ for 
additional information. 

iTunes support 

• View your iTunes playlists in the Sonos Digital Music System by selecting Im-
ported Playlists from the Library tab.

• When you make changes to your iTunes playlist(s), quit iTunes, and then update 
your Sonos music index in order to see the changes (see ’Updating your music 
index’ for help with this step.)

• iTunes playlists will automatically be imported into the Imported Playlists list on 
both the Sonos Controller and Sonos Desktop Controller, as long as your 'iTunes 
Music Library.xml' file is shared along with your music. For typical iTunes installa-
tions, this file is located in the iTunes folder. 

• Sonos is unable to play tracks purchased from the iTunes Music Store, as they are 
protected by Apple's proprietary Digital Rights Management (DRM) scheme. 

For additional information, browse our Frequently Asked Questions (FAQ) pages or 
Forums at http://support.sonos.com.

http://support.sonos.com
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Using Rhapsody
Now you can hear more music in more rooms with Sonos and Rhapsody™, the #1 rated 
digital music service. Sonos connects directly to Rhapsody via the Web, so you don't 
have to download an application or even turn your PC on. 

Your Sonos system comes with a free 30-day Rhapsody trial. Rhapsody subscribers can 
simply click the Music Services tab in the Music Library to browse and select 
Rhapsody content.

Configuring Rhapsody

Creating a free Rhapsody trial account

Your Sonos system comes with a free Rhapsody trial—no signup, no credit card 
necessary. If you did not activate a free Rhapsody trial account while setting up your 
Sonos Digital Music System, you can do it now. (Rhapsody may not be available in your 
country. If the Rhapsody trial does not appear as an option, please click the Get Music 
button for more details.)

1. Select File>Preferences.

2. From the Accounts tab, select Add.

3. Select Rhapsody Trial from the list of Account types.

4. A username and password will be automatically assigned for you. Click OK.

Your free Rhapsody trial account will be valid for 30 days. After that, if you wish to 
become a subscriber, go to www.sonos.com/rhapsody for additional information. 
Once your Rhapsody account is set up, simply add the account information to Sonos in 
order to access Rhapsody from your Sonos Digital Music System (see ’Adding your 
Rhapsody account to Sonos’.) 

Current Rhapsody users who have recently updated to Sonos 2.0

If you are an existing Rhapsody customer, prior to Sonos version 2.0 your computer 
had to be on in order to access your Rhapsody content (the Rhapsody client on your 
computer accessed the Rhapsody server via UPnP.)

To take advantage of accessing Rhapsody via the Web, simply add your Rhapsody 
account to Sonos (’Adding your Rhapsody account to Sonos’)

http://www.sonos.com/rhapsody
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Adding your Rhapsody account to Sonos

If you have a Rhapsody account, simply add the account information to Sonos and 
you’ll have instant access to Rhapsody from the Sonos Digital Music System.

1. Add your Rhapsody account information to Sonos by selecting 
File>Preferences>Accounts>Add.

2. Select Rhapsody from the list of Account types.

3. Enter your Rhapsody username and password and click OK.

4. If you previously had a Rhapsody trial account in place, you will be asked if you 
want to merge the information from your trial account into the new account. If 
you select Yes, any playlists and content selections you saved to My Rhapsody 
Library will be preserved under the new account. 

5. Update your music index whenever you add new content by selecting Update 
Music Index Now from the Music menu. Or you can schedule daily music index 
updates (see ’Scheduling music index updates’.) 

Using Rhapsody with UPnP

If you are using Rhapsody’s desktop application to organize the music on your local 
drive, your Sonos system can access Rhapsody’s server using Universal Plug and Play 
(UPnP). You should only use this method to access Rhapsody if you are using 
Rhapsody’s desktop application, or if you have multiple Rhapsody accounts active in 
your household. Otherwise simply add your Rhapsody account information to 
Sonos— see ’Adding your Rhapsody account to Sonos’.

To access Rhapsody’s server using UPnP, make sure UPnP is enabled in the Rhapsody 
desktop application so that the Sonos Digital Music System can recognize it and show 
Rhapsody in your Music Library. This is a one-time preference setting. Remember— 
your computer must be on in order to stream Rhapsody content if you are accessing 
Rhapsody’s server this way.

From Rhapsody:

1. Start RealRhapsody.

2. Click Tools>Preferences>Rhapsody Server (UPnP).

3. Click to check the Start UPnP Server Once Logged In box, and then click Start.

4. Click OK.
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From Sonos:

1. Select Sonos>Preferences and click the Advanced Options button.

2. Check the Show music from Rhapsody UPnP servers checkbox and click Done. 

Selecting music from Rhapsody

Music selection choices include: 

• Rhapsody Music Guide

• Rhapsody Radio

• My Artists

• My Albums

• My Genres

• My Tracks

• My Playlists

1. From the Music Library pane, click the Music Services tab, and select Rhapsody. 

• If the Music Services tab is not displayed in the Music Library, see ’Showing/hid-
ing the Music Services tab’.

2. Highlight a music selection, and click Play Now, Play Next, or Add to Queue to 
add it to the end of your music queue. If you are selecting music from the 
Rhapsody Music Guide, you can additionally select Add To My Rhapsody Library.

Rhapsody Music Guide

The Rhapsody Music Guide displays a variety of music selections, including a list of 
music genres, top artists, top albums, and top tracks, new releases and Rhapsody-
recommended selections. Click any of the links to browse through the Rhapsody Music 
Guide and make selections.

Rhapsody Radio

1. Select a zone.

2. Click the Music Services tab.

3. Select Rhapsody Radio, and then select a radio station from the My Stations list.

4. Click Play Now.
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Changing your Rhapsody password

If you want to change your Rhapsody password, you must first change it in 
Rhapsody. Go to www.rhapsody.com and select My Account, or if you have 
downloaded the Rhapsody desktop client, you can change from the My Account 
menu.

Once you've changed your password within Rhapsody, you can update the Sonos 
system with the new Rhapsody password using this Accounts>Edit option. 

Deleting a Rhapsody account from Sonos

1. From the Sonos menu, select SonosPreferences.

2. Select the Accounts tab.

3. Select the account you wish to remove, and click Remove.

4. Select Yes to confirm, and then click OK.

Using Audible
The Sonos Digital Music System is compatible with Audible, Inc. (Format 4 file 
downloads only.) If you are interested in signing up for Audible’s spoken word audio 
services, go to http://www.audible.com for more information.

When listening to a book, you can use the Next and Previous keys to move from 
chapter to chapter. 

It’s easy to view your Audible files by genre. From the Music Library, select 
Library>Genres, and select Audiobooks.

Note:   If you don’t change your password within Rhapsody first, it won’t work on your Sonos 
Digital Music System.

http://www.rhapsody.com/
http://www.audible.com
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Other content, such as journals will appear in the Spokenword genre. You may need to 
select All to view your journal content. 

Adding Audible to your Sonos system

1. Make sure your Audible files are in a folder that you have shared to the Sonos 
Digital Music System (using the Select Music Source screen).

2. Add your Audible account information to Sonos by selecting 
Sonos>Preferences>Accounts>Add. 

3. Select Audible as the Account Type. 

4. Enter your Audible username and password and select Add.

5. Reindex your music library whenever you add new content by selecting Update 
Music Index Now from the Music menu.

Deleting an Audible account from Sonos

1. From the Desktop Controller menu bar, select Sonos>Preferences.

2. Select the Accounts tab, and click Remove.

3. Enter your Audible password for verification, and click Remove.

Managing Music Queue (DCR) 
Removing track from the queue

1. From the Queue pane, select a track.

2. Choose one of the following options:

• Select Remove Track, or 

• Select Queue>Remove Track from the Play menu.

The track disappears from the queue list.
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Moving a track within the queue

1. Click the mouse, and while holding, drag the track you want to move within the 
queue.

2. Drag it up or down to the desired location, and then release.

Clearing the music queue

1. Choose one of the following options:

• Select Clear Queue from the bottom of the Queue pane, or 

• Select Queue>Clear Queue from the Play menu.

2. Select Clear to confirm.

This will clear the entire queue and stop the music from playing.

Changing the play mode

1. Select the Shuffle or Repeat buttons displayed in the Now Playing pane to 
change the play mode. 

The selected play mode appears as an icon in the Now Playing pane. 

 Shuffle 

 Repeat

 Shuffle/Repeat

Sonos Playlists (DCR) 
Sonos playlists are music queues you create and save for future listening. 

Creating a Sonos playlist

1. Create a music queue by selecting music tracks from your music library. 

2. Choose one of the following options:

• From the Queue pane, select Save Queue, or 

• Select Queue>Save as Sonos Playlist from the Play menu.

3. Type a unique name for this playlist, and select Save. This queue is now accessible 
from the Sonos Playlists tab.To play a saved queue, select the desired playlist from 
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the Sonos Playlists tab and select Play Now to start the playlist immediately, or 
Add to Queue to add it to the end of your current music queue.

Deleting a Sonos playlist

1. From the Sonos Playlists tab, select the playlist you want to delete.

2. Choose one of the following options:

• Select Delete, or 

• Select Delete Sonos Playlist from the Music menu.

Renaming a Sonos playlist

1. From the Sonos Playlists tab, select the playlist you want to rename.

2. Select Rename Playlist from the Music menu.

Internet Radio (DCR)

Playing an Internet radio station

1. Select the zone you want to listen in.

2. Select the Radio tab.

3. Select a radio station from the list.

4. Select Play Now.

Setting Internet radio preferences

You can receive automatic radio station updates whenever Sonos releases a new list. 
Your music system must be registered in order to receive updates. If you have not yet 
registered, see ’System Registration’.

1. From the Sonos menu, select Preferences.

2. Select the Updates tab. 

3. Choose the desired setting from the Internet Radio Station Updates section.

Adding a radio station

If you know the streaming URL, and the station uses a supported streaming broadcast 
format (see ’Internet Radio’), you can add a radio station to your Favorite Stations list.

1. Select the Radio tab. 
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2. Choose one of the following options:

• Select Add New, or 

• Select Add New Internet Radio Station from the Music menu.

3. Type or paste the streaming URL for the radio station you are adding (for example: 
http://shoutcast.com/sbin/shoutcast-playlist.pls?rn=8107&file=filename.pls.) 

4. Type the radio station’s name in the Station Name field, and select Add.

Editing a radio station

1. Select the Radio tab. 

2. Select an Internet radio station, and then select Edit.

3. Change the streaming URL, the station name, or select Add to Favorites to add 
the station to your Favorite Stations list, and select OK.

Your “Favorites” list

Adding a station to your Favorite Stations list

When you add radio stations to your Favorite Stations list, they are duplicated into your 
Favorites folder, not moved from the original Internet radio list. 

Select a station from the radio list, and select Add to Favorites. 

Deleting a station from your Favorite Stations list

From the Radio tab, select the station you want to delete from your Favorite Stations 
list, and select Delete.

Managing Music Folders (DCR)
The Sonos Digital Music System can play music from any networked computer or 
network-attached storage (NAS) device where you have shared music folders. During 
the setup process, you are guided through the process of accessing your shared music 
folders. Over time, you may wish to add or remove music folders from this list.

Note:   You can edit the streaming URL or station name only for the radio stations that are in 
your Favorites list. However you can add any radio station to your Favorites list using the Edit 
option. 
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These music folders are indexed by the Sonos Digital Music System so that you can 
view your music by categories. If you add new music to a folder that is already indexed, 
you can update your music index to add this music to your library. 

To play music from imported playlists, simply drop the playlist file .PLS, .M3U or .WPL 
into the same music folder that you have shared to the Sonos system, re-index the 
share and the custom playlists will appear when you select Imported Playlists from 
the Music menu.

Adding a shared folder

1. From the Music menu, select Set Up Music Library.

The shared music folders that are currently available to your Sonos Digital Music 
System appear. 

2. Select Add.

Removing a shared folder

1. From the Music menu, choose Set Up Music Library.

2. Select the folder you want to stop accessing music from, and select Remove. 

3. Select Remove to confirm.

4. You may be asked to provide an administrator name and password.

To add music stored in your Music folder, select In my Music folder, and select Continue. 
Click the Lock icon to enter your administrator password. If your computer does not 
currently allow Windows Sharing, you will be prompted to enable it. 
If you have used iTunes Preferences to change where you store iTunes music, this option 
will appear as In my iTunes Music folder instead.

To add music stored elsewhere on your computer, select On my computer or an external 
drive connected to my computer, and select Continue. Select Browse to choose a 
folder, and then select Continue.

To add music stored on a different computer or a NAS device, select On a networked 
device such as a network-attached storage (NAS) device on my network, and select 
Continue. Type the path name (\\Name\Sharename, where Name is the network name for 
your computer or NAS device, and Sharename is the name of the top level shared folder.) 
If this folder is not shared anonymously, type the user name and password of a user with 
rights to access this music folder. 
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5. Select Done when you have no more folders to remove from the list.

Updating your music index

If you add new music to a music folder that is already indexed, you can update your 
music index in order to add this music to your Sonos music library. 

1. From the Music menu, select Update Music Index Now.

2. Select Update.

The message “Updating Music Index” appears at the bottom of the window. 
When the update is complete, the message disappears. 

Scheduling music index updates

You can set your music system to automatically update your music index at the same 
time each day. 

1. From the Music menu, select Schedule Music Index Updates.

2. Select the time you would like your music index to automatically update, and click 
OK.

Software Updates (DCR)
Sonos provides software updates for your music system in order to improve 
performance and add features. Your music system must be registered in order to 
receive these software updates. If you have not yet registered, see ’System 
Registration’. 

There are two options available: 

• Periodically check for updates and send an alert when an update is available. 

• Do not check for updates. 
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Setting software update preferences

1. From the Sonos menu, select Preferences.

2. Select the Updates tab.

3. Choose the desired setting from the Software Update Notifications section. 

Downloading software updates

1. From the Sonos menu, select Check for Updates. 

• Your ZonePlayers as well as your Desktop Controller software will be updat-
ed, as all Sonos components must carry the same software version number. This 
process may take several minutes per device, depending upon your network 
connection. Your Sonos Desktop Controller software will automatically 
quit and then re-open during the update process. 

• Software updates to your handheld Sonos Controller must be initiated from 
your Controller, so if you have updated your DCR, you will be prompted to up-
date your Controller the next time you use it. Simply follow the on-screen 
prompts.

• If your software is up to date, the message “Your Sonos Digital Music System is 
up to date. No updates are required” will appear instead.

ZonePlayer software updates

One or more ZonePlayers may need to be updated when you purchase a new 
ZonePlayer with a later software version, or if you plug in a ZonePlayer that was not in 
use when you performed your last software update. When a ZonePlayer’s software 

Caution:  Do not disconnect power from your ZonePlayer(s), or in any way disable your 
Sonos Digital Music System while this process is running. Contact Sonos Customer 
Support if an error occurs.
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version gets out of sync from the rest of your Sonos Digital Music System components, 
you will see the following message displayed in the Zones pane:

Click the outdated zone to begin the software update process.

Advanced Preferences (DCR)
In addition to ’Setting Internet radio preferences’, ’Setting software update 
preferences’, and ’Showing/hiding the Music Services tab’, you can also change your 
wireless channel, and line-in encoding preferences.

Selecting different wireless channel (DCR)

The Sonos Digital Music System selects the optimal radio frequency channel during 
setup. However, if you have other wireless devices using this channel, you may want to 
switch the Sonos Digital Music System to another channel to avoid conflicts, as 
conflicts may cause audio drop-outs.

1. From the Sonos menu, select Preferences.

2. Select the Advanced tab.

3. Select another wireless channel from the Wireless Channel list.

It may take several seconds for the switch to take effect. If you have music playing, a 
short music dropout will occur during the wireless channel change.
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Line-In encoding (DCR)

The audio from line-in sources can be encoded to produce compressed or 
uncompressed audio. We recommend the following usage guidelines:

• Use Uncompressed if:

• You want optimal performance with home theaters. 
• You want to produce the highest quality sound for your multi-zone Sonos 

system (this selection requires more network bandwidth than compressed 
audio.)

• Use Compressed if:

• You are connecting more than 4 zones wirelessly.
1. From the Sonos menu, select Preferences.

2. Select the Advanced tab.

3. Select Compressed or Uncompressed from the Line-in Encoding list.

When Compressed is selected, you will notice a delay before the music starts to play. 
When Uncompressed is selected, this delay is significantly reduced.

Resetting the Desktop Controller
If you want to join your Macintosh computer to a different Sonos Digital Music System, 
you must first reset your Desktop Controller software. 

1. Choose Reset Desktop Controller from the Sonos menu. 

2. Select Reset.

3. Select Quit.

Your Desktop Controller window will automatically quit. The next time you start the 
Desktop Controller software, the Setup Assistant will appear to prompt you through 
the setup process. If you are joining your computer to an existing Sonos Digital Music 
System, you do not have to press the Mute and Volume Up buttons on every 
ZonePlayer again - just one that is connected to your system via an Ethernet cable. 
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Uninstalling
If you wish to remove the Desktop Controller software from your Macintosh computer, 
choose Uninstall Sonos from the Sonos menu, and then drag the application to the 
trash. The Sonos Digital Music System will no longer be able to access music from this 
computer.

Firewall Information

The Sonos Digital Music System is designed to work with existing firewall software. 
Follow the steps below to see if your firewall allows access to the Sonos Digital Music 
System.

1. Open the System Preferences window.

2. Select the Sharing icon, and then select the Firewall tab. 

3. If the message “Firewall Off” is displayed, your Sonos Digital Music System will be 
recognized and you do not have to do anything further. Select Continue. 

4. If the message “Firewall Off” does not display, you must add access to the ports 
your ZonePlayers will use. 

If your software firewall is not listed, please see http://faq.sonos.com/firewall for the 
latest firewall information, or contact Sonos Technical Support at http://
www.sonos.com/support.

Mac OS X’s built-in firewall for 10.3

The Sonos Digital Music System is fully compatible with the Mac OS X firewall.

1. Open the System Preferences window.

2. From the Internet & Network settings, select Sharing.

3. To access music stored on your computer, check Windows Sharing and select 
Start from the Services tab.

4. From the Firewall tab, select New... 

If the New button is disabled, click the lock at the bottom of the window and enter an 
administrator's password.

5. From the pull-down port name, select Other.

http://faq.sonos.com/firewall
http://www.sonos.com/support
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6. Type or paste the range of ports as 136-139, 445, 1900, 1901, 3400, 6969.

7. Type the description as Sonos, and then select OK.

8. Close the System Preferences window.

Mac OS X’s built-in firewall for 10.4

1. Open the System Preferences window.

2. Select the Sharing icon.

3. Select the Firewall tab.

4. Click the New button.

If the New button is disabled, click the lock at the bottom of the window and enter an 
administrator's password.

5. From the pull-down Port Name menu, select Other.

6. For TCP Port Number(s), type or paste 445,3400.

7. For UDP Port Number(s), type or paste 1900,1901,6969.

8. Type the description as Sonos.

9. Click OK.

10. Close the System Preferences window. 

Norton Personal Firewall for Mac OS X

While you are setting up your Sonos system, you will be asked for network connectivity 
permission. 

1. Select Change, and then Allow to allow connections on these ports.

2. Select Done to confirm.

You will also need to add ports to the service.

3. From the Norton Antivirus Setup window, select New.

4. Name the new entry Sonos, and the description Sonos Controller. 

5. Select New and for TCP Port Number(s), type or paste 445, 3400. For UDP Port 
Number(s), type or paste 1900,1901,6969. 

6. Select Save.
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Internet Security Barrier for Mac OS X

During Sonos system setup, a dialog will open when you attempt to set up your music 
library on your computer. 

1. Select Ignore.

2. Open Netbarrier X3 and select the Anti-vandal tab.

3. Select Add.

4. Browse to the Sonos Desktop Controller application, usually found in the 
Applications folder and click Select.

5. Select Allow as the default behavior.

Enabling Windows File Sharing
1. From the System Preferences window, select the Sharing icon.

2. Select the Services tab.

3. Check the Windows Sharing checkbox.

If an Accounts button appears, you don't need to select it.

4. Close the System Preferences window.

5. Select Continue.



Your Sonos Controller

With a Sonos Controller in hand, you have instant access to your entire digital music 
collection, no matter where it's stored. The full-color LCD screen and intuitive scroll 
wheel make everything from browsing songs to choosing zones incredibly easy. It's 
like having a giant jukebox at your fingertips. Simply choose a zone to play music in, 
make your music selection(s), and press Play.

Features

• Wireless control over all your music and all your zones from anywhere

• Intuitive control over your music and zones with full-color LCD screen and scroll 
wheel that makes it simple to:

• browse songs

• queue up tracks and playlists

• select Internet radio stations

• choose zones

• control volume, playback and system settings
Chapter 5
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Connecting Your Controller
• After at least one ZonePlayer has been set up, follow the instructions on the Con-

troller screen to add this Controller to your Sonos Digital Music System.

• You should charge your new Sonos Controller when you remove it from the 
packaging. The Controller battery will be fully charged in about two (2) hours. 
You can use your Controller while it is charging.

• The power connector cover is part of your Controller’s splash-resistant design, so 
keep the cover down when the Controller is not charging. 

 

Caution: Use only the supplied power adapter to charge the Controller’s battery. Using 
another adapter will damage your Controller and void your product warranty.

AC power adapter

AC power 
adapter 
inlet

Power 
cable

Power 
connector 
cover
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Using the Controller 

Controller navigation

Zones

Use the Zones button to select a zone to play music in, to view the music 
selections playing in each room, or to create or modify zone groups in order to 
share the same music across zones. 

Music

Use the Music button to browse or select music, manage your music queues, 
access playlists, and change the default settings for a Sonos ZonePlayer or 
Controller. 

Back

Use the Back button to return to the previous screen.

Battery 
charge 
indicator

Mute 
button 

Volume 
up(+)  
down (-)

Music 
button

Scroll 
wheel

Back 
button

Battery status 
indicator light

Zones 
button

Labels for 
soft 
buttons 

Soft buttons Playback controls

Light 
sensor

OK button

Wireless 
indicator
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Scroll wheel

Use the scroll wheel to navigate through a displayed list. Use your thumb or 
finger to ‘turn’ the wheel clockwise to scroll down through the list, and 
counterclockwise to scroll up through the list. 

OK

Press the OK button in the center of the scroll wheel to make selections.

Soft buttons

The soft button functions change to reflect the available actions for the 
Controller screen currently displayed. The action for each button appears 
above it (for example, View Queue or Add to Queue). 

Controller playback

Play/Pause

Toggles between playing and pausing the current track. When browsing 
music sources, if you highlight a playable item (track, album, artist, playlist) 
and press Play, the highlighted music item is added to the end of the music 
queue, and begins to play immediately. 

Next (short press)

Jumps to the start of the next track in the music queue. 

Fast forward (long press)

Pressing and holding this button moves you forward through the current 
track. The music playback jumps to the new position when the button is 
released. 

Previous (short press)

If you are more than 3 seconds into the track, this button jumps to the start of 
the current track; if you are less than 3 seconds into the track, this button 
jumps to the start of the previous track.

Rewind (long press)

Pressing and holding this button moves you backward through the current 
track. The music playback jumps to the new position when the button is 
released. 
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Controller volume control

Volume Control

Increases (+) or decreases (-) the volume in any zone, or across a zone group.

Mute

Temporarily silences the music in a zone (within a zone group, the mute 
button automatically mutes the last room where volume controls were 
adjusted.) Press the Mute button again to unmute.

Mute All

To mute all zones in the house, press and hold the Mute button for 3 seconds. 
To unmute all zones, press and hold again for 3 seconds.

Controller sensors and indicators

Light sensor

Automatically turns on the button backlights based upon the lighting 
conditions of the environment. You can adjust the brightness of the buttons 
or the display by selecting System Settings>Controller Settings from the 
Music menu.

Wireless signal strength indicator

Indicates the current strength of the Controller’s wireless signal.

Battery charge indicator

Indicates the Controller’s remaining battery charge. 

Battery status indicator light

Alerts you to the status of the battery charge:

• Lights red when the battery gets low, indicating that the Controller needs to be 
charged

• Lights amber while the Controller is charging

• Lights green when the Controller finishes charging

• Unlit when your Controller is in use and the battery is charged
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Controller sleep modes

Light Sleep. Your Controller will go into light sleep to preserve the battery life when it is 
unused for a specified period of time. The screen will turn off until motion is detected 
or a button is pressed. Use the Sleep Timer Docked (Controller is connected to power 
supply) and Undocked (Controller is not connected to power supply) settings to select 
the amount of time after which your Controller will enter light sleep. 

Deep Sleep. Your Controller will go into deep sleep to preserve the battery life when it is 
unused for a specified period of time. When your Controller wakes from deep sleep - 
either from the motion sensor or from a button press - it will go through a restart cycle 
that takes several seconds. Use the Deep Sleep Timer setting to select the amount of 
time after which your Controller will enter deep sleep.   

Motion Sensor. The Controller has a motion sensor to automatically wake your 
Controller when motion is detected. If you shake the Controller, you may hear the 
motion sensor make a slight rattling sound. This is normal. If you wish to disable the 
motion sensor, Controller Settings>Advanced Settings>Motion Sensor.

Turn off Controller

Use this setting to put your Controller into deep sleep anytime it will not be in use for an 
extended period of time, or when you are transporting your Controller to another 
destination. This setting puts the Controller into deep sleep mode immediately, 
bypassing the deep sleep timer setting. The Controller cannot be turned off while it is 
connected to the AC adapter or charging cradle. From the Music menu, select System 
Settings>Controller Settings>Advanced Settings>Turn off Controller. 

Resetting your Controller

If your Controller’s screen should freeze, press and hold the Mute and Music buttons 
simultaneously on the Controller for approximately 3 seconds. The Controller will reset 
itself momentarily.

Factory reset

If you want to join your Controller to a different Sonos Digital Music System, you must 
first factory reset your Controller. Select System Settings>Controller 
Settings>Advanced Settings>Factory Reset from the Music menu.

The Welcome screen will appear on your Controller to prompt you through the setup 
process. To add your Controller to a Sonos Digital Music System that is already set up, 
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you can press the Volume Up and Mute buttons (when prompted) on any ZonePlayer 
that is part of your music system. 

Controller - Volume Settings

1. From the Zone menu, use the scroll wheel to highlight the zone you want to 
change the volume settings for. 

2. Use the Volume Up and Down buttons to change the volume to the desired level.

3. Press OK, and the Volume panel disappears. 

Muting zone or zone group

• To mute a zone or a zone group, press the Mute button (within a zone group, the 
mute button automatically mutes the last room where volume controls were 
adjusted.) 

• Press the Mute button again to unmute. 

The volume panel appears over 
the current screen. Volume can 
be controlled for a zone group or 
for an individual zone. Use the 
Group Volume bar to control the 
volume for the whole group, 
adjusting each zone’s volume 
proportionately. 

Single zone 
volume bar

Group 
volume 
bar

Mute 
indicator

Mute 
indicator
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Muting all zones (Controller)

• To mute all the ZonePlayers in your household, press and hold the Mute button 
for 3 seconds. 

• To unmute all the ZonePlayers, press and hold the Mute button for 3 seconds.

The Controller Main Menus

Zone menu

• View zones 
• Select zones
• Link or drop zones in a zone group
• Pause all ZonePlayers

Music menu

• View music sources

• Select music from music library, 
music service, Sonos play- 
list, Internet radio, or a line-in mu-
sic source

• Change your music system’s set-
tings
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Managing Zones Using Controller
Press the Zones button on your Controller to: 

• See an alphabetical list of the zones in your household, along with the music cur-
rently playing in each zone

• Group zones together to play the same music across zones (create a zone group)

• Drop a zone from a zone group

• Turn off your music system

Music continues to play while you browse the Zone menu. Use the scroll wheel to 
highlight a zone, and press OK. The Now Playing window appears. You can then press 

the Music button  to change the music selection for that zone.

Note:   The currently selected zone shows at the top of your Controller screen so you can see 
which zone you are making changes to. 

Zones button

Touch the Zones button to view the 
music playing in each room
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Zone groups

A zone can be grouped together with any other zone(s) to form a zone group. This will 
cause all the zones in the zone group to play the same music in synchrony. You can link 
and drop zones from a zone group while your music is playing. You can also link all the 
ZonePlayers in your house with one touch by selecting All Zones-Party Mode. 

Linking a zone

1. Press the Zones button on your Controller.

2. Use the scroll wheel to highlight the zone or zone group that you want to add a 
zone to, and press Link Zone.

3. Highlight the zone you want to add to the group, and press OK. If you want to join 
all the zones in your house to this music queue, select All Zones-Party Mode. All 
of your ZonePlayers will then play the same music in synchrony.

Note:   Any zones you add to a group will automatically drop their current music queue and 
begin to play the music that is playing in the zone group. You may sometimes want to save 
your music queue as a Sonos playlist before linking zones. See Saving a Sonos Playlist.

Note:   The order in which you add zones makes a difference. If you select Link zone from a 
zone where there is no music playing, any rooms you link to it will also be silent. 

Select zone to add to 
group

Select zone where 
desired music is playing 
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The music queue from the added zone is automatically replaced by the music 
queue from the zone or zone group it was linked to, so that both zones play the 
same music. 

Dropping a zone

1. Press the Zones button on your Controller.

2. Use the scroll wheel to highlight the zone group you want to change, and press 
Drop Zone.

3. Highlight the zone you want to drop from the group, and press OK. The room 
that’s removed from the zone group stops playing music. The other zones in the 
zone group continue unaffected.

Clock and Alarms

Setting date and time

1. From the Music menu, select Clocks and Alarms.

2. Select Date and Time Settings.

3. Choose one of the following options:

• Select Time Zone. Use the scroll wheel to select your time zone from the list, and 
then press OK. Next, select Date and use the scroll wheel to set today’s date, 
pressing OK after each entry. If desired, you can change the date and time dis-
play formats by selecting the corresponding options from the Date and Time 
Settings menu.

Select zone 
to drop 
from group 
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• Or, select Select Date and Time from the Internet, and then press OK. Select 
On or Off. When this is on, your Sonos system will periodically update the date 
and time from the Internet. If desired, you can change the date and time display 
formats by selecting the corresponding options from the Date and Time Set-
tings menu.

• Or, you can set the date and time manually. Select Date and press OK. Use the 
scroll wheel to select today’s date, pressing OK after each entry. Follow the same 
process to set the time by selecting Time from the Date and Time Settings 
menu. If desired, you can change the date and time display formats by selecting 
the corresponding menu options.

Adding an alarm

1. From the Music menu, select Clock and Alarms>Alarms.

2. Press New Alarm.

3. Use the scroll wheel to select the desired settings for this alarm, including the 
alarm time, the zone you would like the alarm to play in, the music source you’d 
like to play from, the frequency of the alarm, and the volume setting. Press OK 
after each entry.  

4. Select Advanced to choose these additional alarm preferences: 

• Alarm duration

• Should linked zones also play the alarm(yes or no). If you select Yes, the alarm 
will play in the zones that are linked together when the alarm goes off, not in the 
zones that were linked together at the time the alarm was added.

• Should the clock display on this Controller (yes or no). If you select Yes, the clock 
will display on this Controller when the alarm goes off. 

Note:   If the music you’ve selected is not available (such as an Internet radio station 
that has dropped off), your alarm will play the Sonos chime instead.

Note:   When an alarm sounds, the clock will display on the Controller that was used 
to set the alarm.  If you want the clock to display on another handheld Controller, be 
sure to edit the alarm using the desired Controller. From the Music menu, select 
Clocks and Alarms>Alarms, and then select Advanced>Show Clock on this 
Controller.
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• Should the play mode for the selected alarm music be set to shuffle (yes or no)

5. Press Save Alarm when you finish choosing the alarm settings.

Deleting an alarm

1. From the Music menu, select Clock and Alarms>Alarms.

2. Use the scroll wheel to highlight the alarm you wish to delete, and press Delete 
Alarm.

Setting a sleep timer

1. From the Music menu, select Clock and Alarms>Sleep Timer.

2. Use the scroll wheel to select a sleep timer duration, and press OK.

Viewing the clock

To view the clock on a handheld Controller:

• Select View Clock from the Music menu, or 

• Select Clocks and Alarms>View Clock from the Music menu. 

When an alarm goes off

When the alarm goes off, your Sonos Controller will display the clock face.  You can:

• Press Snooze to begin a 9-minute snooze interval.  The bell icon will be animat-
ed when snooze mode is active.

• Press Stop Alarm or Pause to turn the alarm off. 

• Press Display Off to put the Controller into light sleep mode (helps to preserve 
the battery charge.) The motion sensor will automatically wake your Controller 
when you pick it up.  
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Making Music Selections (Controller)

Browsing your music library

You can browse for songs in a number of different ways. Using the Controller, you can 
make broad music selections like play all available music by a particular artist, or you can 
make specific selections like play a single track by a particular artist on a specified album. 
Selection choices include:

• Artists

• Albums

• Composers

• Genres

• Tracks

• Imported playlists

• Folders

You can change the sorting preference for your music folders to sort by track 
name, track number, or filename. From the Music menu, select 
SystemSettings>Advanced Settings>Sort Folders By. 

Selecting music from your Sonos music library

1. From the Zone menu, use the scroll wheel to highlight the zone you want to play 
music in, and then press the Music button.

2. Select Music Library, and press OK. 

Note:   If a computer on your network is turned off, or is in standby mode, the music folders on 
that computer are unavailable to the Sonos Digital Music System until the computer is turned 
back on.

Note:   The music you select will play in the zone or zone group that is currently showing at 
the top of your Controller screen. 



Chapter 5:  Your Sonos Controller 5-15
3. Use the scroll wheel to browse the music library. Press OK to drill down through 
the menus until you find the desired selection. You can select Power Scroll for an 
alphabetical list to make browsing faster.

4. To play all songs by an artist, on an album, or in a genre, highlight the selection 
and select Add to Queue, or press OK. 

You can change the action of the OK button by selecting System Settings>Controller 
Settings>OK Button from the Music menu. Preference settings include:

• Play Now. Play the selection immediately. 

• Add to End of Queue. Add the selection to the end of your music queue.

• Show Menu. View an options menu so that you can choose from the following: 

• Play Now
• Play Next
• Add to End of Queue

If you’ve created Sonos playlists (tracks you’ve organized into lists), you can play them 
anytime by selecting Sonos Playlists from the Music menu. For more information, see 
Sonos Playlists (Controller).

Note:   If you have uncompressed files in your music collection, they may only be available for 
browsing and/or selection via Track or Browse by Folder, as uncompressed files may not 
contain detailed information such as artist, title and genre.

Power 
scroll
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5. Press the Back button to return to the previous music selection screen.

Playing music from imported playlists (Controller)

The Sonos Digital Music System is compatible with iTunes playlists as well as M3U, WPL 
and PLS playlist files created with third-party software (e.g. iTunes, WinAmp, Windows 
Media Player, etc.).

M3U, WPL and PLS support

• You can view your playlists by selecting Imported Playlists from the Music Li-
brary.

• If they are not visible, they are probably not located in a folder you currently have 
shared with the Sonos Digital Music System. Move the playlist file .PLS, .M3U or 
.WPL into the same music folder that you have shared to the Sonos system, up-
date your music index, and the custom playlists will appear when you select Im-
ported Playlists from the Music Library. See Music Index (Controller) for 
additional information.

iTunes support

• You can view your playlists in the Sonos Digital Music System by selecting Im-
ported Playlists from the Music Library.

• When you make changes to your iTunes playlist(s), quit iTunes, and then update 
your Sonos music index in order to see the changes (see Music Index (Control-
ler))

• iTunes playlists will automatically be imported into the Imported Playlists menu 
on both the Sonos Controller and Sonos Desktop Controller, as long as your 
'iTunes Music Library.xml' file is shared along with your music to the Sonos sys-
tem. For typical iTunes installations, this file is located in the iTunes folder: 

• Windows: \my documents\my music\itunes
• Macintosh: ~/Music/iTunes

• Sonos is unable to play tracks purchased from the iTunes Music Store as they are 
protected by Apple's proprietary Digital Rights Management Scheme. 

For additional information, browse our Frequently Asked Questions (FAQ) pages or 
Forums at http://support.sonos.com.

http://support.sonos.com
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Music services

If you have a music service enabled, click the Music Services tab to make music 
selections. (If you are a Rhapsody user, see Selecting music from Rhapsody for 
additional detail.)

If you don’t currently have a music service enabled, you can click the   button 
to browse the online music and audio services available for use with the Sonos Digital 
Music System. 

Selecting music from Rhapsody

Music selection choices include: 

• Rhapsody Music Guide

• Rhapsody Radio

• My Artists

• My Albums

• My Genres

• My Tracks

• My Playlists

1. From the Music menu, select Rhapsody. 

2. Use the scroll wheel to browse. Press OK to drill down through the menus until you 
find the desired selection. 

3. Press the Play button  to play the music now, or press OK and select one of the 
following: Play Now to play the music now, Play Next to play it next in the queue, 
or Add to Queue to add it to the end of your music queue. If you are selecting 
music from the Rhapsody Music Guide, you can additionally select Add To My 
Rhapsody Library. 

4. You can select Rhapsody sfrom the Now Playing screen to add a track or an 
album to your Rhapsody Library.

Selecting a Rhapsody radio station
1. Select a zone.

2. From the Music menu, select Rhapsody>Rhapsody Radio.
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3. Select a radio station from the My Stations list, and press OK.

Managing Music Queue (Controller)

What is a music queue?

When you make music selections, they are added to a list of tracks called a music queue. 
You can create a music queue for each zone in your house, or you can create a zone 
group and play the same music across multiple zones. A play indicator appears to the 
left of the currently playing track. When the current track ends, the next track in the 
queue starts to play, and play continues down through the list until the queue is 
completed. 

Moving a track

1. Press View Queue.

2. Use the scroll wheel to highlight the song you want to move within the queue.

Note:   You can add tracks to the music queue while other tracks in the queue are 
playing.

Once you have added selections to a music queue, 
you can make changes to the queue list by 

selecting the View Queue soft button.
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3. Press Move Track. 

4. Use the scroll wheel to move through the queue until you find the location you’d 
like to move the track to.

5. Press Place Track.

Removing a track

1. Press View Queue.

2. Use the scroll wheel to highlight the song you want to remove from the queue.

3. Press Edit Queue. 

4. Select Remove Track, and press OK.

The song disappears from the queue list.

Clearing the music queue

1. Press Edit Queue from the View Queue window.

2. Select Clear Queue, and press OK.

This will clear the entire queue and the music will stop playing.

Changing the play mode

1. From the Zones menu, press OK to display the Now Playing screen. 
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2. Press Play Mode. 

3. Use the scroll wheel to select a play mode, and press OK.

The selected play mode appears as an icon on the Now Playing screen. 

 Shuffle. Plays the tracks in the music queue in a random order. 

 Repeat. Repeats the music queue after the last track has finished.

 Shuffle-Repeat. Shows that both play modes are activated.

Viewing large album art

From the Now Playing screen, press the OK button to view larger album art. 

Adding tracks or albums to your Rhapsody Library

From the Now Playing screen, select Rhapsody to add a track or an album to your 
Rhapsody Library.
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Sonos Playlists (Controller) 

Sonos Playlists are music queues you save for future listening. For example, you might 
want to create a jazz playlist, a party playlist, or an easy listening playlist.

Saving a Sonos Playlist

1. From the View Queue window, press Edit Queue. 

2. Select Save Queue, and press OK to save the playlist using the name displayed, or 
select Enter a Different Name and use the keyboard to type another name such 
as jazz or party.

3. Press OK after each letter entry, and then Accept when finished.

You can access these saved Sonos playlists later from the Music menu.

Deleting a Sonos Playlist

1. From the Music menu, select Sonos Playlists, and press OK.

2. Use the scroll wheel to highlight the playlist you want to delete, and press 
Rename/Delete.

3. Select Delete Playlist, and press OK.

4. Select Yes to confirm, and press OK.

Renaming a Sonos Playlist

1. From the Music menu, select Sonos Playlists, and press OK.

2. Use the scroll wheel to highlight the playlist you want to rename, and press 
Rename/Delete.
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3. Select Rename Playlist.

4. Type a new name for the playlist, and then press Accept.

Internet Radio (Controller)
Sonos provides a selection of third-party streaming broadcasts for you to select from. 
You can add additional radio stations using the Sonos Desktop Controller software. 
These additional stations are placed in your Favorite Stations list. 

1. From the Music menu, select Internet Radio.

2. Select the radio station category you want to choose from, and press OK. 

3. Select a radio station from the list, and press Play. It immediately begins to play in 
the zone you have currently selected.

4. To add a radio station from the preset list to your Favorite Stations list, press Add to 
Favorites. 

5. To add a radio station that does not appear in the Sonos supplied list, use the 
Desktop Controller software. 

Music Library Management (Controller)
You can add or remove the shared folders Sonos accesses music from at any time. You 
may need to make changes if you add a computer to your home network, or if you 
move shared folders from one location to another. 

If you add new music to a folder that is already indexed, update your music index to 
add this music to your library. 

To play music from imported playlists, simply drop the playlist file .PLS, .M3U or .WPL 
into the same music folder that you have shared to the Sonos system, re-index the 
share and the custom playlists will appear when you select Imported Playlists from 
the Music menu.

Viewing your shared folders

1. From the Music menu, select System Settings>Music Library 
Management>Music Library Setup.

The shared music folders that are currently accessible to your Sonos Digital Music 
System are displayed. (If a computer on your network is turned off or is in sleep or 
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standby mode, the music on that computer will be unavailable to the Sonos Digital 
Music System until the computer is turned back on.)

Adding a shared folder from the list

1. To make another shared folder available to your Sonos Digital Music System, select 
Add New from the Selected Shared Folders screen. Your network will be 
scanned for shared folders that your music system is not currently accessing. 

2. To select a shared folder from the displayed list, use the scroll wheel to highlight 
the folder, and press OK.

If this shared folder does not require a username and password, press OK and the 
selected folder is added to your music system. 

If this shared folder requires a username and password:

• Use the scroll wheel to highlight the Username field and press Type. 

• Type the name of a user with permission to access this folder, and then press Ac-
cept.

• Use the scroll wheel to highlight the Password field and press Type. 

• Type the password associated with this user, and then press Accept.

Adding a shared folder not displayed in the list

1. Select Add New>Enter New.

2. Press Type... to enter the path for the shared folder. and then press Accept. (path 
example: \\Name\Sharename, where Name is the network name for your 
computer or NAS device, and Sharename is the name of the top level shared 
folder, such as \\linkstation\music_share.)

3. Press OK. 

If this folder is not shared anonymously, you will need to enter a username and 
password:

• Use the scroll wheel to highlight the Username field and press Type. 

• Type the name of a user with permission to access this folder, and then press Ac-
cept.

• Use the scroll wheel to highlight the Password field and press Type. 

• Type the password associated with this user, and then press Accept.
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Stop accessing a shared folder

1. From the Music menu, select System Settings>Music Library 
Management>Music Library Setup, and press OK.

The shared music folders that are currently accessible to your Sonos Digital Music 
System are displayed. 

2. Use the scroll wheel to select the folder you wish to stop using, and press Remove.

3. Press OK.

Your music folder will remain untouched on your computer. However, you will no 
longer be able to access it from the Sonos Digital Music System.

Music Index (Controller)
During the setup process, all of your available music folders are indexed for easy 
selection. If you add new music to a folder that is already indexed, you can simply 
update your music index to add the new music to your Sonos music library. 

Updating your music index

1. From the Music menu, select System Settings, and press OK.

2. Use the scroll wheel to highlight Music Library Management>Update Music 
Index Now, and press OK.

3. Select Yes, and press OK.

The message, “updating music index” appears at the bottom of your Controller screen. 
When the message disappears, your new music is available. 

Scheduling automatic updates

1. From the Music menu, select System Settings, and press OK.

2. Select Music Library Management.

3. Select Music Index Update Time, and press OK.

4. Use the scroll wheel to select the time you would like your music index to update 
each day, pressing OK after each entry.

5. From the Music Library Management menu, select Schedule Music Index 
Update, and press OK.
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6. Select On. Your music index will automatically update at the selected time each 
day. 

To turn off automatic music index updates, select Off.

ZonePlayer Settings

Music equalization

You can change the sound settings (treble, bass, loudness, or balance) for each 
individual ZonePlayer. 

1. From the Music menu, select System Settings>ZonePlayer Settings, and press 
OK.

2. Use the scroll wheel to select a zone, and press OK.

3. Select Music Equalization, and press OK.

4. Select a setting, and then use the scroll wheel to make adjustments to the control 
slide that appears on the screen, and then press OK.

5. To change the settings for a ZonePlayer back to their original default values, select 
Reset All.
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Renaming ZonePlayers

1. From the Music menu, select System Settings>ZonePlayer Settings and press 
OK.

2. Use the scroll wheel to highlight the ZonePlayer name you wish to change, and 
press OK.

3. Select ZonePlayer Name, and press OK.

4. Use the scroll wheel to select a new name from the list, and then press OK.

5. You can also type a unique name by selecting Enter New. 

• Use the scroll wheel to select each letter, pressing OK after each entry.

• Press Accept to accept the new name, or press Cancel to leave the screen with-
out making a change.

White status indicator light

If you have a ZonePlayer located in a bedroom, you may want to turn off the white light 
located on the front of the ZonePlayer. This means that while the ZonePlayer is in 
normal operation, the white light will be off. However, if the ZonePlayer Status Indicator 
Light begins to flash amber, see ZonePlayer Status Indicator Explanations for additional 
information.

1. From the Music menu, select System Settings>ZonePlayer Settings and press 
OK.

2. Use the scroll wheel to select a zone, and press OK.

3. Select White Status Indicator Light, and press OK.

4. Select On or Off and clickOK.

ZonePlayer Status Indicator 
LED; white when in normal 
operation
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Line-In source name

1. From the Music menu, select System Settings>ZonePlayer Settings and press 
OK. 

2. Use the scroll wheel to highlight the zone the audio component is connected to, 
and press OK. 

3. Select Line-In Source Name, and press OK.

4. Choose a new name from the list, and press OK, or select Enter New to type a 
unique name.

Line-In source level

1. From the Music menu, select System Settings>ZonePlayer Settings and press 
OK. 

2. Use the scroll wheel to highlight the zone the audio component is connected to, 
and press OK. 

3. Select Line-In Source Level, and press OK.

4. Choose the line-in level appropriate for this device, and click OK.

The default (typical) line-in level for your device type automatically displays. You 
can increase or decrease the level, but if the level is set too high, you may 
experience clipping at higher volume levels. 
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Controller Settings

From the Music menu, select System Settings>Controller Settings and then use the 
scroll wheel to highlight the preference setting you wish to change.

OK Button 

• Use this preference setting to choose the action that will occur when you select 
a track, and press the OK button. The track can begin to play immediately (Play 
Now), it can be added to the end of your music queue (Add to End of Queue), 
or you can view an options menu (Show Menu) to select one of the following 
actions each time: 

• Play Now
• Play Next
• Add to End of Queue

Click Sound

Adjust this setting to turn the Controller’s scroll wheel “clicking” sound on or off.

Sleep Timer Undocked

Use this setting to select the amount of time after which your Controller enters 
light sleep mode when not connected to a power supply. The screen will turn off 
until motion is detected or a button is pressed. 
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Sleep Timer Docked

Use this setting to select the amount of time after which your Controller enters 
light sleep mode when plugged into the adapter or sitting in the cradle. Because 
the Controller is connected to a power supply during this time, you can set this 
sleep timer significantly higher than the undocked sleep timer setting. 

Screen Brightness

Use this setting to adjust the brightness of the screen display.

Button Brightness

Use this setting to adjust the backlighting of the buttons that occurs when the 
light sensor automatically lights the buttons based upon the lighting conditions 
of the environment.

 Advanced Settings

The Advanced Settings menu provides you with some additional menu choices:

• Deep Sleep Timer. Use this setting to set the deep sleep timer for your Control-
ler. Your Controller will go into deep sleep to preserve the battery life when it is 
unused for this specified period of time. When your Controller wakes from deep 
sleep - either from the movement sensor or from a button touch - it will go 
through a restart cycle which takes several seconds.

• Motion Sensor.   Use this setting to turn the motion sensor on or off. The motion 
sensor automatically wakes your Controller when motion is detected.

• Language. Use this setting to select your language preference. When you 
change your language preference, the Controller restarts.

• Turn Off Controller.  Use this setting to put your Controller into deep sleep any-
time it will not be in use for an extended period of time, or when you are trans-
porting your Controller to another destination. This setting puts the Controller 
into deep sleep mode immediately rather than waiting for the deep sleep timer 
setting to be reached. The Controller cannot be turned off while it is con-
nected to the AC adapter or charging cradle.

• Factory Reset. Use this setting to return the Controller to its original factory set-
tings. This will disconnect the Controller from your Sonos Digital Music System 
entirely (you can add it again at any time.) This may be necessary if the Controller 
gets associated to the wrong music system during setup, or if you wish to join 
your Controller to another Sonos Digital Music System.   
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Online Updates (Controller)
Sonos periodically provides you with software updates to improve performance or to 
add new features. Your music system must be registered in order to receive updates. If 
you have not yet registered, see System Registration. 

Checking for updates

1. From the Music menu, select System Settings>Online Updates and press OK. 

2. If there is an update available, select Yes to begin the update process.

• Your ZonePlayers and Controllers will all be updated, as your Sonos compo-
nents must carry the same software version number. This process may take sev-
eral minutes per device, depending upon your network connection. 

• If you have the Desktop Controller software installed, you will be prompted to 
update it the next time you start the application.

Controller software updates

In the event that your Controller’s software version gets out of sync from the rest of 
your Sonos Digital Music System components, you will see the following message 
displayed on your Controller screen the next time you use it: 

Caution: Do not disconnect power from your ZonePlayer(s), or in any way disable your 
Sonos Digital Music System while this process is running. Contact Sonos Customer 
Support if an error occurs.
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This Controller will be unavailable for use until you perform a software update to bring 
the Controller up to date. This situation will occur if you perform a software update 
from another Controller, or from the Desktop Controller software.

ZonePlayer software updates

If a ZonePlayer’s software version gets out of sync from the rest of your Sonos Digital 
Music System components, you will see the following message displayed on your 
Zones menu:

1. Press OK to begin the software update process.

One or more ZonePlayers may need to be updated 
if you purchase a new ZonePlayer with a later 
software version, or if you plug in a ZonePlayer 
that was not in use when you performed your last 
software update.

You will also see this message if you have already 
updated your music system using the Controller. 
This message will indicate that the Desktop 
Controller software needs to be updated.
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Advanced Settings (Controller)
Upon occasion, it may become necessary to adjust some of the default settings for 
your Sonos Digital Music System. You can also use the Advanced Settings menu to 
register your music system if you have not yet registered it.

Auto check for software updates

Sonos can automatically check your system for available software updates. Your music 
system must be registered in order to receive updates. Change your preference by 
following the steps below. 

1. From the Music menu, select System Settings.

2. Select Advanced Settings>Auto Check for Software Updates. 

3. Select On to turn auto checking on, or Off to turn auto checking off, and then click 
OK (On is the default setting.) 

Auto update Internet radio station list 

You can receive radio station updates automatically whenever Sonos releases a new 
list. Your music system must be registered in order to receive updates. Change your 
preference by following the steps below. 

1. From the Music menu, select System Settings.
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2. Select Advanced Settings>Auto Update Internet Radio Station List. 

3. Select On to turn auto update on, or Off to turn auto update off, and then click OK 
(On is the default setting.)

Sort folders by

You can set the sorting preference for music folders that are accessible from your music 
library. You can choose to sort by:

• Track name

• Track number

• Filename

Line-In encoding

When you have line-in music sources attached to a ZonePlayer, line-in encoding 
determines how the Sonos Digital Music System will encode the data coming in from 
these sources. For multi-room audio, we recommend the Compressed setting. For the 
highest quality sound, you can select Uncompressed encoding instead (note that this 
selection requires more network bandwidth than compressed audio.) For TV or DVD 
audio, we recommend the Uncompressed setting.

1. From the Music menu, select System Settings.

2. Select Advanced Settings>Line-In Encoding.

3. Use the scroll wheel to select Uncompressed or Compressed encoding, and 
press OK. When Compressed is selected, you will notice a slight delay before the 
music starts to play.

Selecting a different wireless channel

The Sonos Digital Music System selects the optimal radio frequency channel during 
setup. However, if you have other wireless devices using this channel, you may want to 
switch the Sonos Digital Music System to another channel to avoid conflicts, as 
conflicts may cause audio drop-outs.

1. From the Music menu select System Settings.

2. Select Advanced Settings>Wireless Channel. 

3. Use the scroll wheel to select a different wireless channel, and press OK.



Sonos Digital Music System User Guide5-34
It may take several seconds for the switch to take effect. If you have music playing, a 
short music dropout will occur during the wireless channel change.

Battery Charging (Controller)
Your Controller can be recharged by plugging it into the AC adapter supplied with your 
Controller, or by placing it into the Charging Cradle. The battery charge indicator  
on your Controller will show you when it is time to recharge the Controller. If the 
battery charge is very low, the Controller’s low-battery indicator will light red. Be sure to 
recharge using only the AC adapter supplied with your Sonos Controller.

Battery Replacement (Controller)
After several years (depending upon usage), the battery on your Controller may not 
hold a charge as long as it once did. Because of the Controller’s splash-resistant design, 
the battery on the Controller must be factory-replaced. Return it to the Sonos Service 
Center where it will be promptly replaced and returned to you. Go to http://
www.sonos.com/support for instructions and battery replacement cost.

Caution: Use only the supplied power adapter to charge the Controller’s battery. Using 
another adapter will damage your Controller and void your product warranty.

Caution: Danger of explosion if battery is incorrectly replaced. Replace only with the 
same or equivalent type. Return to Sonos or an authorized Sonos service center for 
replacement.

http://support.sonos.com


Tips and Troubleshooting

Basic Troubleshooting

If a problem occurs, you can try the solutions listed in the troubleshooting section. If 
you are unable to remedy the problem:

• Visit the Sonos Customer Service Web site at http://www.sonos.com/support.

• Give us a call. Go to www.sonos.com/support/phone_support to find the cor-
rect telephone number for your country.

• Ask us a question at http://faq.sonos.com/ask.

Desktop Controller software won’t run

• During the setup process, if the Desktop Controller for Windows software does 
not start automatically, run “d:\setup.exe” replacing “d” with your CD-ROM 
drive’s letter as necessary.

ZonePlayer not detected during setup

A network problem may be preventing the ZonePlayer from associating with the 
Desktop Controller software. If this is a wireless ZonePlayer, try moving the ZonePlayers 
closer together, or wire the ZonePlayer temporarily to see if the problem is related to 
wireless interference. 

If you encounter this message on the first wired ZonePlayer, you can try the steps 
below to resolve this issue:

Warning: Under no circumstances should the product be repaired by anyone other 
than an authorized Sonos repair center, as this will invalidate the warranty. Please 
contact the Sonos Customer Service Center for an authorized repair center in your 
area. Do not open the system as there is a risk of electric shock. 
A

http://www.sonos.com/support
http://faq.sonos.com/ask
http://www.sonos.com/support/phone_support/index.htm
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1. Check Firewall

Firewall software installed on the computer may be blocking the ports that Sonos uses 
to operate. The first step is to disable all your firewalls and try to connect again. If this 
resolves the problem, then configure your firewall to work with the Sonos music 
system. Click Firewall InformationFirewall Information for help with this step. If this 
does not resolve the problem, go on to step 2.

2. Check Router

You can bypass your router’s switch to see if there are any router configuration issues 
(note that the ZonePlayer and the computer will still have Internet access in this 
configuration):

• Be sure that your cable/DSL modem is connected to the router’s WAN (Internet) 
port. 

• Temporarily remove any other components that are wired to your network. 

• Connect an Ethernet cable from the computer directly to the back of the Zone-
Player, and then connect another Ethernet cable from the ZonePlayer directly to 
one of the LAN ports on your router. 

• When you make a change to your network configuration, you may need to pow-
er cycle the ZonePlayer by unplugging the power cord, and then plugging it 
back in.

• If you are not using a router, see http://faq.sonos.com/norouter.

http://faq.sonos.com/norouter
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3. Check Wiring

Check the link/activity lights on both the router and the ZonePlayer. They should be 
green, and there should be blinking activity lights. 

• If the green link lights are not lit, try connecting to a different port. 

• If the link lights still do not light, try connecting a different Ethernet cable.

4. DHCP/AutoIP Issues

It is possible that the ZonePlayer or PC has failed to obtain a valid IP address for your 
network. This can be caused if the DHCP server on your router is unable to lease an IP 
address to the ZonePlayer, forcing the ZonePlayer to use Auto IP. You can use the 
Controller to determine the IP address of your ZonePlayers by pressing the Music 
button, and then selecting System Settings>About Your Digital Music System.

Check the IP address of your computer and make sure the first two numbers of the 
ZonePlayer and the PC's IP addresses are the same. For example the PC might have an 
IP address of 192.168.0.100 and the ZonePlayer an IP address of 192.168.0.101. The first 
two numbers of the IP address match so they are on the same network and both have 
received their IP address from a DHCP server. If the PC had an IP address of 
192.168.0.100 and the ZonePlayer had an IP address of 169.254.11.23 then you’d know 
there is a problem because the first two numbers don't match. If this is the case then 
you need to reset your router and the ZonePlayer and try again.

Go to our Web site at http://faq.sonos.com/dcrsf for additional assistance.

ZonePlayer isn’t operating properly

• If the ZonePlayer status indicator is not lit and no sound is produced when the 
unit is plugged in, check the insertion of the power cord.

• Check to ensure that the ZonePlayer Status indicator on the front of the Zone-
Player is illuminated and solid white. If it is flashing or solid amber, see ZonePlay-
er has stopped playing music.

• Check to ensure that the green link light is lit on the Ethernet switch on the rear 
panel of the ZonePlayer wired to your network.

• Move the Controller closer to the unit.

• Check to ensure there are no obstacles to impede wireless operation.

• Check your network connections.

• The ZonePlayer may need to be reset. Disconnect the power cord for 5 seconds, 

http://faq.sonos.com/dcrsf
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and then reconnect. Wait for the ZonePlayer to restart.

• If none of these work, the ZonePlayer may need to be factory reset. Discon-
nect power, and then reconnect while pressing and holding the Mute button 
until the Mute indicator light begins to flash amber. Use the Controller or the 
Desktop Controller software to add it to your music system again.

 ZonePlayer status indicator lit, but no sound

• Make sure speakers are connected securely.

• Make sure volume is set to a suitable level. 

• Make sure MUTE is not on. 

ZonePlayer volume level reduces 

If the ZonePlayer status indicator changes to solid amber, and the volume reduces to 
75%, this indicates that the ZonePlayer is experiencing a fault condition. 

• Check the ZonePlayer vents to ensure they are not blocked.

• Check for speaker short circuit.

• Mute ZonePlayer or unplug it for several minutes to allow it to cool. 

ZonePlayer has stopped playing music

If a ZonePlayer stops playing music, and the ZonePlayer status indicator lights are 
flashing (long amber, short white, repeat) this indicates that the ZonePlayer has 
experienced a fault condition and has automatically muted itself to prevent damage to 
the ZonePlayer. 

• Check the ZonePlayer vents to ensure they are not blocked.

• Check for speaker short circuit.

• Unplug the ZonePlayer for several minutes to allow it to cool. 

• Mute and unmute the ZonePlayer.

Sound produced from only one speaker 

• Make sure speaker is connected securely.

Note:   You should not factory reset all of your ZonePlayers at once or all preferences and 
Sonos playlists will be lost.
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• Make sure balance control is set correctly.

Cannot access Internet radio, online updates, or registration

• Your firewall may be blocking outgoing connections to the Internet. Ensure the 
firewall allows access to the Internet for the Ethernet addresses of your Sonos 
components. 

• Your firewall may be configured so that Sonos components cannot obtain an IP 
address. If so, your ZonePlayers and Controllers will display an IP address in the 
169.254.xxx.yyy range, even though there is a router/DHCP server on the net-
work. (You can check the IP addresses assigned to your ZonePlayers by selecting 
Music>System Settings>About Your Digital Music System.) The DHCP serv-
er built in to some routers may be configured to supply IP addresses only to de-
vices with specific permitted Ethernet MAC addresses. If you have configured 
your router in this way, you will need to grant permission to the Ethernet MAC 
address of each Sonos component (including the Controller) before setting up 
your system. Go to http://faq.sonos.com/dhcp for more information.   

There’s a delay when I play music from an external music source

If Compressed is selected as the encoding method for your line-in music source, you 
will notice a delay before the music starts to play. When Uncompressed is selected, 
this delay is significantly reduced. 

Controller screen is frozen

Your Controller may need to be reset. Press and hold the Mute and Music buttons 
simultaneously on the Controller for approximately 3 seconds. The Controller will reset 
itself momentarily. 

Controller not displaying proper zones

If the Controller is not displaying your zones properly, displays the message, “Searching 
for ZonePlayers...”, or is acting sluggish:

• Make sure at least one ZonePlayer is plugged in and its status indicator is illumi-
nated solid white.

• The ZonePlayer(s) may be going through an upgrade/restart, and will reappear 
after they restart.

• Move the Controller closer to the ZonePlayer.

http://faq.sonos.com/dhcp
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• You may be experiencing interference from another wireless device. Change the 
wireless channel your Sonos Digital Music System is operating on by selecting 
System Settings>Advanced Settings>Wireless Channel.

• Your Controller may be configured to work with a different Sonos Digital Music 
System. Disconnect the Controller from the Sonos Digital Music System, and 
then re-add it. 

To disconnect the Controller:

• Touch System Settings>Controller Settings>Advanced Settings>Factory 
Reset from the Music menu. 

Or,

• If the message “Searching for ZonePlayers” is displayed, touch Settings>Facto-
ry Reset.

Controller doesn’t work in some parts of my home

• Move the Controller closer to a ZonePlayer.

• Change the wireless channel your Sonos system is operating on by selecting 
System Settings>Advanced Settings>Wireless Channel.

Music stops when I use my 2.4 GHz cordless phone

Change the wireless channel your Sonos Digital Music System is operating on by 
selecting System Settings>Advanced Settings>Wireless Channel.

Wrong album art displayed

If the incorrect album art, or no album art appears, please visit our Web site at http://
faq.sonos.com/art for details on how album art is located and displayed.

Some Internet radio stations don’t play

Internet radio stations are broadcasts provided by 3rd parties. Problems related to the 
reliability of stations should be directed to the broadcaster directly. Go to http://
faq.sonos.com/radio for additional information.

http://faq.sonos.com/art 
http://faq.sonos.com/radio
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Can I Eliminate The First Wire?
It is possible to use a wireless bridge to eliminate the first wire in your Sonos™ Digital 
Music System. However this is an unsupported configuration, and as such, technical 
questions should be directed to the Sonos forums, (http://forums.sonos.com/) and not 
to Sonos Technical Support. 

Wireless bridge setup example

Tested, compatible hardware

• Linksys WET54GS5

Tested, not compatible hardware

• D-Link DWL-G810

http://forums.sonos.com
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ZonePlayer Status Indicator Explanations

ZonePlayer 
Status 
Indicator

Mute Button 
Indicator

State Additional 
Information

Solid white Off Powered up, connected 
to the network

Solid white Solid green Muted room

Solid white Flashing green 
to solid green

Muted whole house

Flashing white Off Powering up (booting)

Flashing white Flashing green Powered up, not 
connected to a Sonos 
system

Flashing in unison

Flashing white Flashing green Looking for a Sonos 
Digital Music System

Flashing alternately
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Flashing amber Off Powering up in reset 
mode

Solid amber ZonePlayer fault 
warning

The ZonePlayer is 
beginning to experience a 
fault condition and will 
reduce to 75% volume.
• Check the ZonePlayer 

vents for adequate 
cooling

• Check for speaker short 
circuit

• Mute and unmute the 
ZonePlayer

• Unplug the ZonePlayer 
for several minutes to 
allow it to cool 

Long amber, 
short white, 
repeat

ZonePlayer fault 
shutdown (mute)

If the fault condition 
(above) is not remedied, 
the ZonePlayer will 
automatically mute itself to 
prevent damage to the 
ZonePlayer

Solid or flashing 
red

Diagnostics mode You may be instructed to 
enter Diagnostics mode by 
a technician when you call 
Customer Support to 
report a problem. 

If you accidentally enter 
diagnostics mode, touch 
the Mute button to exit. 
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About Your Music System
If you make a call to Sonos Customer Support, you may be asked for specific details 
regarding your Sonos Digital Music System. You can find this information by choosing 
one of the following options:

• From the Music menu on your Sonos Controller, select System Settings>About 
Your Digital Music System. 

Or,

• From the Sonos Desktop Controller for Windows menu bar, select Help>About 
Sonos Desktop Controller.
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Or,

• From the Sonos Desktop Controller for Macintosh menu bar, click Sonos>About 
Sonos.
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Support Diagnostics
Support Diagnostics should only be accessed when you are talking with a Sonos 
Support representative (800-680-2345). For general Sonos support information, go to 
http://www.sonos.com/support.

From your Desktop Controller software: 

1. From the SonosFile menu, click Preferences.

2. Click the Diagnostics tab.

3. Click Submit Diagnostics if you are instructed to by your Sonos Support 
representative.

Can’t Find What You’re Looking For?
If you can’t find the answer to your question in our documentation, please visit our 
Frequently Asked Questions (FAQ) pages at http://www.sonos.com/support or ask us 
a question at http://faq.sonos.com/ask.

http://www.sonos.com/support
http://www.sonos.com/support
http://faq.sonos.com/ask


Sonos Device Specifications

Sonos ZonePlayer ZP100

Feature Description

Audio

Rated Output 50W minimum RMS per channel (8 Ohms, 20-20kHz, 
THD+N<0.02%)

Speaker Connections Spring binding posts

Line In Auto-detecting RCA type

Line Out RCA type, variable audio output

Subwoofer Output Auto-detecting RCA type, 80 Hz crossover

Music Access

Audio Formats Supported  Compressed MP3, WMA, AAC (MPEG4), Ogg Vorbis, Audible 
(format 4), Apple Lossless, FLAC (lossless) music files, as well 
as uncompressed WAV and AIFF files.
Native support for 44.1kHz sample rates. Additional support 
for 48kHz, 32kHz, 24kHz, 22kHz, 16kHz, 11kHz, and 8kHz 
sample rates.
Apple "Fairplay" and Microsoft "Plays-for-sure" DRM-encrypted 
and WMA Lossless formats not currently supported. Firmware 
upgradeable to support future audio formats.

Audio Services Supported Rhapsody (3.0+), Audible 
B
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* Specifications subject to change without notice.

Operating Systems (for 
stored files)

Windows 2000, Windows XP or later, including Windows XP 
Media Center; Macintosh OS X 10.3 or later; NAS (network-
attached storage) devices supporting CIFS

Internet Radio Streaming MP3 or WMA

Ethernet Connection 4-port switch, 10/100 Mbps, auto MDI/MDIX

Wireless Connectivity Sonosnet™, a secure AES encrypted, peer-to-peer wireless 
mesh network

Network Bridging 4-port switch allows Ethernet devices to connect through 
SonosNet™ 

Internet connectivity DSL, cable modem or LAN-based high-speed Internet 
connection required. Internet functionality may require 
payment of separate fee to a service provider.

General

Power Supply AC 120/240, 50-60 Hz, user-switchable

Front Panel Buttons Volume and Mute

Front Panel LED Indicators ZonePlayer status and Mute status

Dimensions 10.2” x 8.2” x 4.4” (260 x 209.5 x 113 mm)

Weight 10 lbs. (4.5 kg) 

Operating Temperature 32 º to 104º F (0º to 40º C)

Storage Temperature 4 º to 158º F (-20º to 70º C)

Finish Die-cast matte aluminum enclosure on light gray base
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Sonos ZonePlayer ZP80

Feature Description

Audio

Sound Quality THD+N<0.009%, 20-20kHz

Line In Analog (RCA), auto-detecting

Line Out Analog (RCA), digital (optical and coaxial)

Music Access

Audio Formats Supported  Compressed MP3, WMA, AAC (MPEG4), Ogg Vorbis, Audible 
(format 4), Apple Lossless, FLAC (lossless) music files, as well 
as uncompressed WAV and AIFF files.
Native support for 44.1kHz sample rates. Additional support 
for 48kHz, 32kHz, 24kHz, 22kHz, 16kHz, 11kHz, and 8kHz 
sample rates.
Apple "Fairplay" and Microsoft "Plays-for-sure" DRM-encrypted 
and WMA Lossless formats not currently supported. Firmware 
upgradeable to support future audio formats.

Audio Services Supported Rhapsody (3.0+), Audible 

Operating Systems (for 
stored files)

Windows 2000, Windows XP or later, including Windows XP 
Media Center; Macintosh OS X 10.3 or later; NAS (network-
attached storage) devices supporting CIFS

Internet Radio Streaming MP3 or WMA

Ethernet Connection 2-port switch, 10/100 Mbps, auto MDI/MDIX

Wireless Connectivity Sonosnet™, a secure AES encrypted, peer-to-peer wireless 
mesh network

Network Bridging 2-port switch allows Ethernet devices to connect through 
SonosNet™ 
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Internet connectivity DSL, cable modem or LAN-based high-speed Internet 
connection required. Internet functionality may require 
payment of separate fee to a service provider

General

Power Supply AC 100/240, 50-60 Hz

Front Panel Buttons Volume and Mute

Front Panel LED Indicators ZonePlayer status and Mute status

Dimensions 5.4” x 5.5” x 2.9” (136.0 x 139.7 x 74.0 mm)

Weight 1.5 lbs. (.69 kg) 

Operating Temperature 32 º to 104º F (0º to 40º C)

Storage Temperature 4 º to 158º F (-20º to 70º C)

Finish Light gray/high quality PC grade
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Sonos Controller CR100 

* Specifications subject to change without notice.

Feature Description

Display and User Interface 

Screen Type Transflective LCD screen, with adjustable backlighting

Screen Resolution 3.5” (diagonal) color LCD, 240 x 320 (QVGA)

Browse Control Touch-sensitive scroll wheel with center-mounted selector 
button

Function Buttons 9 Backlit buttons, 3 soft-selector buttons below screen

Indicators Wireless signal strength and battery charge indicator (on-
screen), battery status indicator LEDs

Power/Connections

Battery Type
Battery Charging Time

Rechargeable Li-ION Polymer battery, factory replaceable
2 hours to fully charge

DC Charger Input 100-240 VAC, 50/60 HZ, Output 6 VDC, 3.8 A

Auxiliary Power Connection Bottom-mounted charger contacts

Wireless Connectivity Sonosnet™ a secure AES encrypted peer-to-peer wireless 
mesh network

General

Dimensions 6.5”x 3.8” x 0.95” (165mm x 97mm x 24.5mm)

Weight 12.5 oz. (360 g)

Finish Metal cladding on light gray enclosure, splash-resistant
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Sonos Loudspeaker SP100 

* Specifications subject to change without notice.

Feature Description

Audio

Bandwidth 75 Hz-20kHz±3dB

Sensitivity 85dB @ 2.83 volts/1 meter

Nominal Impedance 8 ohms 

Crossover Frequency 1.850 kHz

Power handling 75 watts (125 watts peak)

Drive Components Two-way system using one 1" (2.5cm) magnetically shielded, 
Teteron dome driver with 5.5" (14cm) magnetically shielded 
polypropylene copolymer core woofer.

General

Dimensions 11.3 x 6.4 x 7.6 in. (288 high x 163 wide x 194 deep mm)

Weight 10.5 lbs (4.7 kg)

Finish Dark grey/charcoal grey

Speaker Wire 10 ft. of 14-gauge cable provided for each speaker



Other Operating Systems - Setup 

If your operating system is not Windows XP, Windows 2000, or Macintosh OS X (version 
10.3 or later), you can use the Sonos Controller to configure your music system and set 
up access to your music files. The Sonos Digital Music System will recognize many 
standard shared folders on your computer or network-attached storage (NAS) device. 
For additional information, visit our Web site at http://faq.sonos.com/sharing.

If you have digital music files stored on a computer or other device on your home 
network such as network-attached storage (NAS), the computer directories or folders 
that contain these music files must be shared so that the Sonos Digital Music System 
can access them. Before you begin, enable file sharing on each computer that holds the 
music files you want to access. 

System Setup Using Controller
If you are setting up a NAS device without a router, see Setup Using Only a NAS Device 
(no router) instead.

1. From the Welcome screen, touch OK to begin the setup process. 

Note:   If you have just purchased a new Sonos Controller CR100 (purchased separately), you 
should charge the battery. Connect your Sonos Controller to the power adapter using the 
adapter cable. You can use your Controller while it is charging.
C

http://faq.sonos.com/sharing


Sonos Digital Music System User GuideC-2
2. Follow the Controller’s on-screen prompts to connect and then name your 
ZonePlayer

Once the ZonePlayer is successfully initialized, the ZonePlayer Status indicator will stop 
flashing and change to solid white (normal operation), and the Mute indicator will go 
off.

3. Touch OK.

4. When you see the message System is Now Setup, touch OK. 

You may release the buttons as soon as the Mute indicator (green) and the 
ZonePlayer Status indicator (white) start to blink alternately.
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5. Touch the Music button, and then select System Settings>Music Library 
Management >Music Library Setup.

6. Touch Add New. At this point the Sonos System may detect your share 
automatically.  If it is detected, highlight the shared folder, and touch OK.

7. If it is not detected, touch Enter New.

8. Touch Type... to enter the path for this folder. Type \\Name\Sharename, where 
Name is the network name for your computer or NAS device, and Sharename is 
the name of the top level shared folder (for example, \\linkstation\music_share), 
and then touch Accept.

9. Touch OK. 

If the folder is not shared anonymously, you will be prompted to enter a username 
and password. When required:

• Use the scroll wheel to highlight the Username field and touch Type. 
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• Type the name of a user with permission to access this folder, and then touch Ac-
cept.

• Use the scroll wheel to highlight the Password field and touch Type. 

• Type the password associated with this user, and then touch Accept.

10. To add another ZonePlayer to your music system, see Adding More Sonos 
Components.

Setup Using Only a NAS Device (no router)
1. Attach the power cord to a ZonePlayer and plug into a wall outlet.

2. Using your handheld Controller, touch OK from the Welcome screen. 

3. Follow the Controller’s on-screen prompts to connect and then name your 
ZonePlayer

You may release the buttons as soon as the Mute indicator (green) and 
the ZonePlayer Status indicator (white) start to blink alternately.
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Once the ZonePlayer is successfully initialized, the ZonePlayer Status indicator will stop 
flashing and change to solid white (normal operation), and the Mute indicator will go 
off.

4. Touch OK.

5. Connect the NAS device to your computer, and then access the Web 
Configuration utility (see your product documentation for instructions on setting 
a static IP). Through this interface, specify a static IP address for the NAS of 
169.254.x.x (e.g. 169.254.10.100) and a subnet mask of 255.255.0.0.

6. Once you have saved these settings, disconnect the NAS box from your computer 
and connect it to one of the 4 Ethernet ports on the ZonePlayer. 

7. Touch the Music button on your Controller twice to display the Music menu. 

8. Select System Settings>Music Library Management >Music Library Setup.

9. Select Add New. At this point the Sonos System may detect your share 
automatically. If it does not, select Enter New>Type… 
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10. Type the path for this folder, \\NASname\sharename, where NASname is the 
network name for your NAS device and sharename is the name of the top level 
shared folder, and then touch Accept.

11. Touch OK.

12. If the folder is not shared anonymously, you will be prompted to enter a username 
and password. When required:

• Use the scroll wheel to highlight the Username field and touch Type. 

• Type the name of a user with permission to access this folder, and then touch Ac-
cept.

• Use the scroll wheel to highlight the Password field and touch Type. 

• Type the password associated with this user, and then touch Accept.
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play music 4-9
playback controls 3-5, 4-5
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